Find the answer to your Linux question:
Results 1 to 4 of 4
Hello, I know that perfect peripheral support can't be expected out of Linux ... but I am hoping I can find some help. I am a bit of a newbie ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2006
    Posts
    8

    Kodak Z740 digital camera problems in SUSE 10.0


    Hello,

    I know that perfect peripheral support can't be expected out of Linux ... but I am hoping I can find some help. I am a bit of a newbie but willing to learn new things to get my camera to work...

    I am using SUSE 10.0 (with KDE 3.5), and my camera is a Kodak Z740. I tried to use the program digikam to access the pictures on my camera, but my kind of camera was not supported. Also, if I tried to access it as a USB Mass Storage Device, then simply ... nothing happened. :/

    Also, SUSE automounts it. If I use Konqueror and go to "media:/" then I can see all of my storage devices, and when the camera is on it is listed among them. So, I can tell that SUSE has recognised the camera is there. However, if I click on the camera, then it takes a very long time to load and, when it finally does load, all that is shown is a folder that says "USB PTP class Camera." If I click on this folder, I'm taken to ... a window that once again shows "USB PTP class Camera." It basically does that for infinity, and I can never see my pictures. (I know they are there, because if I turn the camera on when it is not plugged in I can still browse through them.)

    So, I am wondering if anyone knows why this is. (Maybe it is a bit of a newbie question ...) Or, if there's a driver or something available so that I can use my camera??

    Thank you very much for any help you can offer ... I'm a very confused newbie right now. It's fun to learn, but I don't know where to start with this problem. (Sorry if this message is too long, or if I have not provided all the information that I should!)

  2. #2
    Just Joined!
    Join Date
    Jan 2006
    Posts
    77
    this is what i do for my canon a410: i open digikam->camera->add camera->autodetect. the idea is that most new cameras use a protocol called PTP (which i think kodak invented) so it should detect a PTP class camera (or something similar). hope that helps,

  3. #3
    Just Joined!
    Join Date
    May 2005
    Location
    Dallas, Texas
    Posts
    95
    Hi Chex,

    I've also run into a snag or two getting digital cameras working with linux, but don't despair you should be able to work through this pretty easily. I did a quick google of "Z740 linux", and found an article where they happen to have tested the same camera on Linux with good results. The first thing I would have you verify is that you have set the camera to act as a USB hard drive. You hinted at this, but I just want to make sure you have it set this way. Once you have verified this, plug the camera into your computer, turn the camera on, and go to a console window and try to view the folder suse makes in the /media folder. You may find that you can access the files from the command line even if konqueror is having problems (this happened to me once).

    If this doesn't work, (still from the command line), login as root and then type (or paste):

    Code:
    fdisk -l
    and post what it shows back to this thread.

  4. #4
    Just Joined!
    Join Date
    Nov 2006
    Posts
    32
    i've got a kodak cx7530
    shows up in konqueror but displays no photos
    I added the camera to digicam and I can connect to the camera but when I go to download the files to my computer it says
    Failed to download file 100B8633.JPG. Do you want to continue?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •