Find the answer to your Linux question:
Results 1 to 6 of 6
My printer, a Brother HL-2070N, is set up on a network through the router on its own (no computer connected). It works fine on the other Windows computers in the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586

    Problems setting up Brother HL-2070N Printer


    My printer, a Brother HL-2070N, is set up on a network through the router on its own (no computer connected). It works fine on the other Windows computers in the network and I've gone as far as being able to access it so it prints something but it often just spits out ~10 blank pages. When I print a test page, it prints some jibberish (2 lines) on the first page then prints out several more blank pages (this is after I attempted to get the driver working properly).

    Can someone please help me get this working?

    This is what I did to try to get it working so far and now I'm stumped:
    I copied the .ppd file from the install CD to /usr/share/cups/model/ and attempted to install it using "gnome-cups-add" but got an error saying that it doesn't have an Acrobat-4.x header....so I looked at the other, default, drivers available on my system and added the first line from one of them that seems relevant to that error. Now, it installed the driver fine but prints blank pages...

    Thanks in advance!!
    josh

  2. #2
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586
    *bump*
    can someone please help me? i would really appreciate it...i feel that i've almost got it set up and it would be really nice to be able to print from my computer

  3. #3
    Linux Enthusiast
    Join Date
    Jun 2005
    Location
    Odessa, FL
    Posts
    586
    *back to the top*

    should i just quit? this would really be a major convenience to get this working. as it is right now, i have to go to my dad's laptop to print anything....and that frustrates both him and me for very little to no reason

    thanks in advance

  4. #4
    Linux Enthusiast deltaflyer's Avatar
    Join Date
    May 2005
    Posts
    577
    how did you set up connection from your distro ? i found i had to use lpd to get my hp5740 working properly. might work

    andy
    SLOMO: acer extensa 5235 2.2ghz,2gb ram 160gb hdd wireless
    SPEEDY: homebrew desktop,Amd x2 dualcore,2gb ram,500gb +1tb( 2x500gb) hdd suse 11.3,32mb fibreline
    registered linux user #401845

  5. #5
    Just Joined!
    Join Date
    Mar 2006
    Location
    Groton, NY
    Posts
    2

    Lightbulb Brother HL2070N under Fedora Core 4

    I was having some trouble setting up the same printer in Fedora Core 4.

    The printer configuration tools didn't seem to be updated by the driver RPM that I installed from Brother.

    Here's how I got it to work, step by step:

    get the drivers from Brother: http://solutions.brother.com/linux/s...ivers.html#red

    (follow their instructions for installing the rpm's)

    To install the lpr driver, I needed to create the symbolic link to /etc/init.d/cups because their install script points to /etc/init.d/lpd which did not exist in my directory tree.

    # ln -s /etc/init.d/cups /etc/init.d/lpd

    The CUPS driver installed just fine.

    I disabled SELinux, since their drivers aren't supposed to be able to work with it.

    Next, go to the web admin interface for the printer:

    Open a browser and enter the ip address for your printer.

    If you don't know what it is, try to find out if it was assigned an address by your router using your router's dhcp client table. If you can't find it listed, print the printer settings page by pressing the "Go" button three times.

    You will be prompted for a username and password, by default this is "admin" & "access".

    You may now configure your printer with a static IP address in the range that you used for your LAN, that way you will always know where to find it.

    Since Fedora didn't have HL2070N listed in the known printers even after installing the new drivers, and using a driver for a different model wouldn't work, I used the CUPS web admin interface.

    This can be found by opening a browser and going to "localhost:631"

    it will prompt you for a user name and password. This is "root" & whatever your root password is.

    Go to Manage Printers, if it is not listed, add it. You may even wish to delete it and start from the begining.

    CUPS will walk you through a series of dialogs to set it up.

    This worked for me. I hope that it works for you or assists you in some way.

  6. #6
    Just Joined!
    Join Date
    Aug 2007
    Posts
    3

    Same issue in SuSE 10.1 with Brother HL-2070N

    Caprarius,

    Thank you so much for the detailed instructions. I am having the same problem with this printer in SuSE, and I have good confidence that your directions will work. However, I am currently having an issue with the rpm install. I download the file to the desktop, double click on it, and click install, but I get the following error message:

    (Since I'm a newbie, I have no clue what it means)

    Installing cupswrapperHL2070N-2.0.1-1.i386[Local packages]
    There are no installable providers of brhl2070nlpr for cupswrapperHL2070N-2.0.1-1.i386[Local packages]


    It sounds to me, like it might be trying to download other components from an external site, but no sources of download are available?

    In case it was the symbolic link thing, I tried that. But it didn't work.

    Thanks in advance for your help! (It really means a lot to a newbie)
    Tbear

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •