Find the answer to your Linux question:
Results 1 to 2 of 2
hi, i am relitively new to linux, i have got mandriva 2006 on a old tiny box with the latest kernels, i have got all of my hardware set up, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2006
    Posts
    2

    Unhappy OV519 Webcam driver help


    hi,
    i am relitively new to linux, i have got mandriva 2006 on a old tiny box with the latest kernels, i have got all of my hardware set up, apart from my Chicony iCam 330 (model DC-3120) which has a OV519 sensor/chip. i have installed the "Linux OVCam Drivers" from http://alpha.dyndns.org/ov511/ and they didnt work so i downloaded "Ov51xJpegHacked" which is a hacked version with the decompressors but, after starting all the modules i recive the folowing errors/messages when running "dmesg":-

    /home/dan/Documents/ov51x-jpeg-0.5/ov51x.c: [ov51x_set_default_params:3961] 640x480, RGB24
    /home/dan/Documents/ov51x-jpeg-0.5/ov51x.c: [ov519_mode_init_regs:3719] width:640, height:480, mode:4, sub:0
    /home/dan/Documents/ov51x-jpeg-0.5/ov51x.c: [ov51x_reset:1202] Reset: type=0x0f
    /home/dan/Documents/ov51x-jpeg-0.5/ov51x.c: No decompressor available

    and when i run "v4l-conf" i get:-

    v4l-conf: using X11 display :0
    dga: version 2.0
    mode: 1024x768, depth=24, bpp=32, bpl=4096, base=0xe2000000
    can't open /dev/video0: Function not implemented

    i have made sure that all my permissions are set right so all users can access the device i have been trying for days to get this to work.
    has anyone else run into the same trouble?
    anyone fixed it?
    i have been searching google but cant seem to fix it using other suggestions

    any help would be greatly apreciated.

    Grunty

  2. #2
    Just Joined!
    Join Date
    Mar 2006
    Posts
    2

    Smile

    dw fixed it myself
    i did make clean at the end of the installation process and removed the original driver fully

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •