Find the answer to your Linux question:
Results 1 to 2 of 2
Well, it's been a while since I found a problem that reading documentation and searching the forums didn't clear up, but here it is. I recently bought an Epson Perfection ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2004
    Location
    Midwest
    Posts
    43

    Epson 2450 giving I/O error


    Well, it's been a while since I found a problem that reading documentation and searching the forums didn't clear up, but here it is.
    I recently bought an Epson Perfection 2450 PHOTO scanner after I found out that it was completely supported through sane as well as the new iscan and epkowa backend from epson.

    I fearlessly emerged xsane and sane-backends. I first tried to use the epson backend so, I set the options in /etc/make.conf to
    SANE_BACKENDS="epson"
    and emerged sane-backends.
    I added myself to the scanner group and logged out and back in.

    I hooked up the scanner and ran
    sane-find-scanner -q

    which gave the correct output, as well as
    scanimage -L

    which also behaved flawlessly. I then got cocky and ran Xsane
    The scanner was detected properly and I set it up to scan an image.

    It failed spitting out the error message
    "Failed to start scanner: Error during device I/O"

    I tried again, re-emerging sane-backends without the SANE_BACKENDS option and was greeted by the same error.
    Needless to say, after each try I power cycled the scanner... just in case.

    I then went through and added the information to the /etc/hotplug/usb/libusbscanner and /etc/hotplug/usb/lisane.usermap in order to be sure that the permissions were being set by hotplug.

    Same problem persisted.

    I then emerged iscan from epson and added the line
    epkowa
    to the /etc/sane.d/dll.conf file and commented out the epson line
    I then commented out the relavent portions of /etc/sane.d/epson.conf and uncommented the relavent lines of /etc/sane.d/epkowa.conf
    I unhooked it, reattached and reran the sane-find-scanner -q and scanimage -L, which both returned the proper results for my scanner.

    I then ran iscan and was greeted with the following message
    "could not send communication to scanner. Check Scanner status."

    I did, the scanner was fine.

    On a lark I hooked up to a windows box nearby to test the hardware. The scanner performed flawlessly on that box confirming my suspicion that it was a linux issue.

    I tried an assortment of options after that, all returning the same error.
    I even booted up a spare debian partition, and loaded the scanner on there. I fired up kooka to test it and was greeted with one successful preview scan. When I went to do the final scan, the scanner dropped out again.

    After that one try in Debian, it began giving me the same error as in Gentoo.

    I noticed that after running scanimage -L and receiving a correct idenitification, if I would try to run it again, the identification would fail until I turned the scanner off and on again.

    This is most annoying, and I am obviously missing something very simple anbd trivial here that would explain why I cannot communicate with my scanner. Anyone who has a working epson who might be able to help, please do. I bought this scanner because if the rave reviews linux users have given it. I'd like to know if it is simply user error or if I have a serious problem here.

    Thanks in advance.

    -Joe


    P.S. I checked my kernel config for the OHCI usb support. I also tried several usb ports on my computer in the process of my tests.

  2. #2
    Just Joined!
    Join Date
    Oct 2004
    Location
    Midwest
    Posts
    43
    anybody got an idea? I still haven't found a solution on my own. If you even own and use an epson scanner using either the epson or epkowa backends, please let me know how your configuration is set.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •