Find the answer to your Linux question:
Results 1 to 7 of 7
I just want to share with you people how I got my Logitech MX mouse to work. I did try a lot of very complicated HOW-TO (involving udev, evdev, xbindkeys, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211

    Mouse: Logitech MX


    I just want to share with you people how I got my Logitech MX mouse to work.

    I did try a lot of very complicated HOW-TO (involving udev, evdev, xbindkeys, etc.), but as always, the simplest solution works best.

    This HOW-TO is specific for the MX500, on Debian GNU/Linux, but it should work with most MX mice and distros.

    Just replace your mouse section in /etc/X11/XFConfig-4 or /etc/X11/xorg.conf with this one:

    For XFree86 4.3 and Xorg 6.8.2 (ex: Debian Sarge, Suse 10.0, Fedora Core 4, etc.)
    Code:
    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ExplorerPS/2"
    Option "Resolution" "800" #optional
    Option "Buttons" "7"
    Option "ZAxisMapping" "4 5"
    EndSection
    For Xorg 6.9 and Xorg 7.0 (Debian Etch, Fedora Core 5, etc.)
    Code:
    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ExplorerPS/2"
    Option "Resolution" "800" #optional
    Option "Buttons" "10"
    Option "ZAxisMapping" "4 5"
    Option "ButtonMapping" "1 2 3 6 7"
    EndSection
    That's it, all the buttons will work perfectly in Mozilla and Mozilla Firefox (even those back/forward buttons on the side).

    For back/forward to work properly in Konqueror, you have to set up "imwheel", but that is left as an exercice.

    Thanks to:
    http://www.cs.cornell.edu/~djm/ubunt...-5button-mouse
    http://ubuntuforums.org/showthread.p...985#post901985
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  2. #2
    Just Joined!
    Join Date
    Dec 2008
    Posts
    4
    I tried this an it worked for a few weeks. I have Logitech USB MX518 mouse.

    Not sure what changed since then but I am back to where just the scroll wheel and two buttons work.

    I checked the xorg.conf and the changes I made are still there. Any one else having this problem?

  3. #3
    Just Joined!
    Join Date
    Jan 2009
    Posts
    2
    Does this work with HAL? All my input devices in xorg.conf are commented out, but still work, but not all the buttons. I am using Ubuntu 8.10 and a usb MX518. I know this is an old thread but still applies to me.

  4. #4
    Just Joined!
    Join Date
    Dec 2008
    Posts
    4
    1) What is HAL

    2) It worked fine for me, I just needed to reboot.

    You can always try it out and if it does not work change it back.

  5. #5
    Just Joined!
    Join Date
    Jan 2009
    Posts
    2
    Quote Originally Posted by Sahrjd View Post
    1) What is HAL
    Hardware abstraction layer - Wikipedia, the free encyclopedia

    Without changing anything in the xorg.conf and running xev, I can see all the buttons but the "+" and "-". Left button is 1, scroll button is 2, right button is 3, scroll up is 4, scroll down is 5, thumb back is 8, thumb forward is 9 and window button is 10.

    Also is there a way to change what the buttons do?

  6. #6
    Just Joined!
    Join Date
    Dec 2008
    Posts
    4
    Thanks for the help.

    I am working on transitioning to Linux for a majority of my computer work. It is a difficult transition. I know the MS products very well and feel a little incompetent workign with Linux.

  7. #7
    Just Joined!
    Join Date
    Dec 2008
    Posts
    4
    Okay, so the buttons work in Opera but not in Firefox v 3.0.5.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •