Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
Just installed another hard drive on my old Pentium II system ( Dell M/B ) but Linux ( rh9 ) doesn't see it as hdc, although the BIOS sees it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2004
    Posts
    17

    The invisible hard drive...


    Just installed another hard drive on my old Pentium II system ( Dell M/B ) but Linux ( rh9 ) doesn't see it as hdc, although the BIOS sees it and gives no error message. hda is a 6Gig Maxtor, hdb is a 120G WD, and hdc, now, is a 4G WD. hdd is the dvd/CDrom. Tried booting into Win98SE, and that OS doesn't 'see'' it either..any thoughts? The drive itself is fine and is recognized by a WD disk formatting utility in its present location as hdc. I installed it as hda, and booted with it, and it worked fine. Curioser and curioser! Is it a hardware problem, or OSs?

  2. #2
    Linux User Mado's Avatar
    Join Date
    Jun 2003
    Posts
    255
    Not formatted?

    If it's not formatted as Fat32/16 it's not going to show up in Windows98. Likewise, I don't think it'll show up in Linux as an formatted drive, but I'm not sure.

    If it is formatted then I'm not really sure why it wouldn't be showing up.
    Live in the sunshine, swim the sea, drink the wild air...

  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Linux doesn't care if it's formatted or not - it will still be accessible as hdc.

    dHarryBear, can you check the output of this command?
    Code:
    for hd in a b c d; do echo $hd; cat /proc/ide/hd$hd/model; cat /proc/ide/hd$hd/driver; done
    Also, are you absolutely sure that you set the master/slave setting correctly on the driver?

  4. #4
    Just Joined!
    Join Date
    Jan 2004
    Posts
    17
    Here's the output-does it tell you anything? As for the jumpers, yes, I'm sure that they are correct, especially since the BIOS sees all the drives.

    a
    cat: /proc/ide/hd: No such file or directory
    ide-disk version 1.17
    b
    cat: /proc/ide/hd: No such file or directory
    ide-disk version 1.17
    c
    cat: /proc/ide/hd: No such file or directory
    (none)
    d
    cat: /proc/ide/hd: No such file or directory
    ide-cdrom version 4.59

    It, too, says "(none)"...? I'll re-boot from the WD disc , and try it again. Should I alter/install something regarding the /proc/ide/hd file?

  5. #5
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    That it says `(none)' is actually a relatively good sign. It means that it has found the drive but not assigned any driver to it. Could you post the output of the following (right after rebooting)?
    Code:
    dmesg | egrep 'ide|hd.'

  6. #6
    Just Joined!
    Join Date
    Jan 2004
    Posts
    17

    Here it is...

    [root@x1-6-00-0c-"xx"-"xx"-"xx"-"xx" root]# dmesg | egrep 'ide | hd. ' (..pls. excuse my paraoid'ya)...

    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    8K byte-wide RAM 5:3 Rx:Tx split, autoselect/Autonegotiate interface.
    [root@x1-6-00-0c-phumpht'a"-c1 root]#

    ......talk it t'me...

    ...?!?

  7. #7
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    You weren't supposed to put those spaces inside the regexp to egrep... It hides all the relevant results.

  8. #8
    Just Joined!
    Join Date
    Jan 2004
    Posts
    17

    I'm Lost. then...whut..?

    You've lost me... w h u u t ...!!!/??!?

  9. #9
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    you should have typed *exactly* what dolda said.. no extra spaces anywhere.. so it's actually:

    Code:
    dmesg|egrep 'ide|hd'
    no spaces in the 'ide|hd' part...
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  10. #10
    Just Joined!
    Join Date
    Jan 2004
    Posts
    17

    oh!

    BIOS-provided physical RAM map:
    Kernel command line: auto BOOT_IMAGE=linux ro BOOT_FILE=/boot/vmlinuz-2.4.20-8 hdc=ide-scsi root=LABEL=/
    ide_setup: hdc=ide-scsi
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hdaMA, hdbMA
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdcMA, hddMA
    hda: Maxtor 90645D3, ATA DISK drive
    hdb: WDC WD1200JB-32EVA0, ATA DISK drive
    hdc: WDC AC14300R, ATA DISK drive
    hdd: TOSHIBA DVD-ROM SD-R1312, ATAPI CD/DVD-ROM drive
    ide2: ports already in use, skipping probe
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
    ide1 at 0x170-0x177,0x376 on irq 15
    hda: host protected area => 1
    hda: 12594960 sectors (6449 MB) w/512KiB Cache, CHS=784/255/63, UDMA(33)
    hdb: host protected area => 1
    hdb: 234441648 sectors (120034 MB) w/8192KiB Cache, CHS=14593/255/63, UDMA(33)
    ide-floppy driver 0.99.newide
    hda: hda1 hda2 hda3 < hda5 > hda4
    hdb: hdb1 hdb2 < hdb5 hdb6 hdb7 hdb8 hdb9 hdb10 hdb11 >
    ide-floppy driver 0.99.newide

    ================================

    OK! So the LINUX 'BIOS" ( for want of the correct term...Linux kernel? ) sees it, too, then...?

    It might be of some help for me to tell you that I originally had my DVD/CDrom set up as the only drive secondary ( master, not CS ), but now it is the slave to the WD14300' as master...

    I can see that I need to change something, here..?

    -dHarryBear

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •