I'm currently running CentOS 4, the latest version, I'm having trouble getting my firewire card/iPod to work. I've used a number of distros before and all have detected this card without issue. When I run the hardware browser, it tells me the card is detected and the ohci1394 module is used as the driver. Makes enough sense to me. Again, lspci shows this:

Code:
02:08.0 FireWire (IEEE 1394): Agere Systems FW323 (rev 05)
Good stuff so far. However, /etc/modprobe.conf is as follows:
Code:
[root@CentOS usb]# cat /etc/modprobe.conf
alias eth0 forcedeth
alias eth1 8139too
alias scsi_hostadapter sata_nv
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
No mention of loading the firewire module. My main HD is Sata, so I know scsi emulation works fine. I also know my iPod isn't detected at all because ls /dev/sd* shows this:
Code:
[root@CentOS dan]# ls /dev/sd*
/dev/sda  /dev/sda1  /dev/sda2  /dev/sdb  /dev/sdc  /dev/sdd  /dev/sde
When I run modprobe ohci1394 I get the module could not be found error.

Any ideas?