Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 19 of 19
yes that gave me alittle sound. A short blip i guess it was but ti was defintiely something. What does that mean? Thanks again for all your time....
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jan 2004
    Posts
    48

    yes that gave me alittle sound. A short blip i guess it was but ti was defintiely something. What does that mean? Thanks again for all your time.

  2. #12
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It just means that you have some other audio device (a USB one), and since it was detected first, all programs try to use it (this is the kind of thing that the 2.6 kernel will remedy - I can't wait for it to happen). Try running the following commands as root - it should fix it for all eternity:
    Code:
    rm /dev/{dsp,mixer}
    mknod /dev/dsp0 c 14 3
    mknod /dev/mixer0 c 14 0
    ln -s dsp1 /dev/dsp
    ln -s mixer1 /dev/mixer

  3. #13
    Just Joined!
    Join Date
    Jan 2004
    Posts
    48
    Wow thank you so much, that worked perfectly. Now all i have to learn is why it worked...lol. That is for another day i suppose. Thank you very much for all your help i can finally listen to all my music .

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Well, see, currently Linux works by putting the first audio device it finds on /dev/dsp0, the next one on /dev/dsp1 and so on. Programs often expect you to only have a single audio device installed, so they simply use /dev/dsp. Since USB devices are probed before sound card drivers are loaded, your USB audio thingie (whatever it is) was put on /dev/dsp0. Thus, the programs tried to use it instead of your sound card which was put on /dev/dsp1.

    Like I said, this is the kind of thing that the 2.6 kernel will allow distribution makers to fix painlessly.

  6. #15
    Just Joined!
    Join Date
    Jan 2004
    Posts
    48
    Wow i just dont knwo what to do. The sound worked for a while but then i left the computer for a while and wheni came back and tried to play a mp3 i got this from XMMS
    1. You have the correct output plugin selected
    2. No other programs is blocking the soundcard
    3. Your soundcard is configured properly
    Now i tried all of the output plugins on XMMS and none worked. There are no other programs even open so i cant imagine anything is blocking the sound. The soundcard i assumes is still configured properly as i didnt change anything. Please i am totally lost and so incredibly frustrated. What do i do. Should i just wait and upgrade the kernel...or wait for core 2.

  7. #16
    Just Joined!
    Join Date
    Jan 2004
    Posts
    48
    Well i guess i am just dumb. I rebooted and the sound works fine again. Sorry about that last post.

  8. #17
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    That was nonetheless really weird... I'm going to assume it was just cosmic rays for now... =)

  9. #18
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    in the settings for xmms in the first tab click the "configure" button.. there should be a location where you can edit the sound device location. change it to /dev/dsp this should work. sorry i cant be more specific but im on a windows machine at the local library! sick!

    ps: everyones avatars look really crap in IE. (cus they are png's with transparancy and IE dont support web standards!!!)

  10. #19
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Oh no, variant - MSIE supports PNG transparency perfectly. You just need a little addition to the page:

    http://support.microsoft.com/default...;en-us;Q294714

    :-/

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •