Find the answer to your Linux question:
Results 1 to 4 of 4
I have removed Win XP and installed Ubunto on the 20gig (slave) while I had the (master) disconnected. Put the (master) back and tried to boot, I stiil can't get ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    fvs
    fvs is offline
    Linux Newbie
    Join Date
    May 2005
    Location
    Scranton, Pa
    Posts
    166

    Hard Drive Dilemma!


    I have removed Win XP and installed Ubunto on the 20gig (slave) while I had the (master) disconnected. Put the (master) back and tried to boot, I stiil can't get the (slave) to boot. I'm just trying to boot from either hard drive, Which I have installed, Seagate 80 gig (master) which has Fedora 5 and WD 20 gig (slave) which has Ubunto only no win XP at all. All I want is to be able to switch drives from the boot. I really don't care about Win Xp, trying to stick with linux all the way.
    Thanks. fvs

  2. #2
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,933
    There is a grub option you can give called 'map' that lets you change the designation of drives at bootup; this may solve your problem. Take a look at the man page for grub, it might give you enough information to use the option as I'm not all that familiar with it.
    Linux user #126863 - see http://linuxcounter.net/

  3. #3
    Just Joined!
    Join Date
    Oct 2005
    Posts
    1
    Just curious, did you check the basics; bios set to boot on hd0 [primary master], the 80g is set to master and the 20g is set to slave..? If all the h/w is correct, the grub will need to be edited [as mentioned].
    I used have a win drive as a secondary master and would just re-set the bios to hd2, [secondary master].

  4. $spacer_open
    $spacer_close
  5. #4
    fvs
    fvs is offline
    Linux Newbie
    Join Date
    May 2005
    Location
    Scranton, Pa
    Posts
    166

    Smile

    Hi Lnx, I have all working well now, I guess the problem is solved, thanks to a lot of community help, It was the grub.conf that solved the problem. All that have had the same situation should add this to solve theirs,


    title Windows XP
    map (hd0) (hd1)
    map (hd1) (hd0)
    rootnoverify (hd1)
    chainloader +1

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •