Find the answer to your Linux question:
Results 1 to 7 of 7
My machine's a Fujitsu-Siemens AMILO A1667G (the 3700+ model) and I'm trying to configure X to have hardware acceleration enabled (the gfxcard is a radeon X700). I've installed what I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    6

    X700 accelleration enabling


    My machine's a Fujitsu-Siemens AMILO A1667G (the 3700+ model) and I'm trying to configure X to have hardware acceleration enabled (the gfxcard is a radeon X700).

    I've installed what I think are the appropriate drivers, and after setting it up my laptop could use 1280x800 and everything was much clearer. However, I've still not got hardware acceleration, and my GL_VENDOR is still set to Mesa.

    My xorg.conf is relatively small compared to others I've seen but it enables X to run well besides the lack of accelleration:

    Code:
    # File generated by XFdrake.
    # **********************************************************************
    # Refer to the XF86Config man page for details about the format of
    # this file.
    # **********************************************************************
    
    Section "ServerLayout"
    	Identifier     "layout1"
    	Screen      0  "aticonfig-Screen[0]" 0 0
    	InputDevice    "Keyboard1" "CoreKeyboard"
    	InputDevice    "SynapticsMouse1" "CorePointer"
    EndSection
    
    Section "Files"
    
        # Multiple FontPath entries are allowed (they are concatenated together)
        # By default, Mandrake 6.0 and later now use a font server independent of
        # the X server to render fonts.
    	FontPath     "unix/:-1"
    EndSection
    
    Section "Module"
    	Load  "dbe" # Double-Buffering Extension
    	Load  "v4l" # Video for Linux
    	Load  "extmod"
    	Load  "type1"
    	Load  "freetype"
    	Load  "synaptics"
    	Load  "glx" # 3D layer
    	Load  "/usr/X11R6/lib/modules/extensions/libglx.a"
    	Load  "dri"
    EndSection
    
    Section "ServerFlags"
    
        #DontZap # disable <Crtl><Alt><BS> (server abort)
     # allows the server to start up even if the mouse does not work
        #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
    	Option	    "allowmouseopenfail"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard1"
    	Driver      "keyboard"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "gb"
    	Option	    "XkbOptions" "compose:rwin"
    EndSection
    
    Section "InputDevice"
    	Identifier  "SynapticsMouse1"
    	Driver      "synaptics"
    	Option	    "Protocol" "auto-dev"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "MinSpeed" "0.09"
    	Option	    "MaxSpeed" "0.18"
    	Option	    "BottomEdge" "4200"
    	Option	    "SHMConfig" "on"
    	Option	    "FingerLow" "25"
    	Option	    "LeftEdge" "1700"
    	Option	    "MaxTapMove" "220"
    	Option	    "MaxTapTime" "180"
    	Option	    "FingerHigh" "30"
    	Option	    "VertScrollDelta" "100"
    	Option	    "RightEdge" "5300"
    	Option	    "TopEdge" "1700"
    	Option	    "AccelFactor" "0.0015"
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]"
    	Driver      "fglrx"
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]"
    	Device     "aticonfig-Device[0]"
    	Monitor    "aticonfig-Monitor[0]"
    	DefaultDepth     24
    	SubSection "Display"
    		Virtual   1280 800
    		Depth     24
    	EndSubSection
    EndSection
    Is it just something missing from the .conf file that is stopping my accelleration working? Or do I need to install something that I've completely forgotten about? Currently glxgears is getting around 180fps.

    Thanks in advance

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Which distro are you using?
    How did you install the ATI drivers? Which version did you install?
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Just Joined!
    Join Date
    May 2006
    Posts
    6
    Thanks for a fast response.
    I'm using Mandriva 2005LE, and I've installed 8.25.18 which is the 35mb .run file. This appeared to install without a hitch and like I say, it allowed me to choose 1280x800 (once I'd added it to the xorg.conf, after running aticonfig) and everything became much clearer as opposed to the previous generic-driver 1024x768 (even 1024x768 using ATI drivers looks far sharper).

  4. #4
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,126
    What framerates are you getting in glxgears? Can you post the results of running glxinfo from the terminal?

  5. #5
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    First make a backup of your /etc/X11/xorg.conf then edit it in conformity with this (you are missing some "modules" plus some other things too):
    http://xoomer.virgilio.it/flavio.sta...html#configure
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  6. #6
    Just Joined!
    Join Date
    May 2006
    Posts
    6
    WOW
    I have absolutely no idea how this has happened
    30 minutes ago I had no hardware acceleration
    but now

    3000FPS in glxgears
    Chromium BSU working like a charm

    I'll have to write this one off as a miracle thanks for the help guys

    PS just checked my xorg.conf and it appears to be the same as before
    ahh well

  7. #7
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Ok then. Hope it stays that way... (Miracles like that are suspects.)
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •