Find the answer to your Linux question:
Results 1 to 9 of 9
Me again, you are all probably sick of me by now, sorry. So, I have no sound on my computer. I am running Xandros 3.0 Deluxe with a Audigy 2ZS ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! WebThingy's Avatar
    Join Date
    May 2006
    Location
    Bellingham, WA
    Posts
    69

    No Sound with Audigy 2ZS on Xandros 3.0 Deluxe


    Me again, you are all probably sick of me by now, sorry.

    So, I have no sound on my computer.

    I am running Xandros 3.0 Deluxe with a Audigy 2ZS sound card.

    I tried the trick on the Xandros FAQ about going into the sound mixer and clicking the yellow bubble for the Analog output. Did nothing.

    I disabled my onboard sound. Still nothing.

    In my sound mixer (default one with Xandros) it does show only my Audigy 2ZS card.

    Any ideas how I can get this running? I manage a record label and find audio useful

    Help very much appreciated.

  2. #2
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    try opening a terminal and typing

    alsamixer


    then raise all your volumes and press M to unmute channel (the only important ones are really PCM and MASTER)
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  3. #3
    Just Joined! WebThingy's Avatar
    Join Date
    May 2006
    Location
    Bellingham, WA
    Posts
    69
    Ok I opened it up but all the volumes are halfway up, I forgot to mention that Dapper Dan had me do that already, sorry, totally slipped my mind. Nothing is muted in there.

    Any other ideas? I hope. please...so soundless...lol

  4. #4
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    What Spencerf mentions is the solution to most sound problem in Linux, that's for sure.

    What is the output of
    Code:
    lsmod | grep snd
    You should have a module called "snd-emu10k1" in there.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  5. #5
    Just Joined! WebThingy's Avatar
    Join Date
    May 2006
    Location
    Bellingham, WA
    Posts
    69
    I'd imagine so, I'd have never known unless someone told me, lol.


    Ok, the Output is...

    snd_emu10k1 104964 1
    snd_rawmidi 25248 1 snd_emu10k1
    snd_seq_device 8588 2 snd_emu10k1,snd_rawmidi
    snd_ac97_codec 74616 1 snd_emu10k1
    snd_pcm_oss 50976 0
    snd_mixer_oss 18304 1 snd_pcm_oss
    snd_pcm 89480 3 snd_emu10k1,snd_ac97_codec,snd_pcm_oss
    snd_timer 24964 2 snd_emu10k1,snd_pcm
    snd_page_alloc 9860 2 snd_emu10k1,snd_pcm
    snd_util_mem 4608 1 snd_emu10k1
    snd_hwdep 9248 1 snd_emu10k1
    snd 55172 11 snd_emu10k1,snd_rawmidi,snd_seq_device,snd_ac97_co dec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,sn d_hwdep
    soundcore 9696 1 snd

    I have no idea what any of that means, lol, ahhhh learning new stuff. wheee!

  6. #6
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    well, you have a the correct modules, you system is recognizing your device and you have raised and unmuted your card so the problem, assuming all those things are correct, probably is something really simple like: speakers aren't hooked up right, speakers aren't on, speaker volume is turned off.

    do you get any sound from

    cat /dev/urandom > /dev/dsp
    hit ctrl + c to end the annoying noice if you get one.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  7. #7
    Just Joined! WebThingy's Avatar
    Join Date
    May 2006
    Location
    Bellingham, WA
    Posts
    69
    Weird, I ran that command and got the annoying noise. hit control + c to stop it.

    But still couldn't get sound from anything else.

    I rebooted and suddenly *poof* SOUND!

    Thanks man!!!

  8. #8
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    no problem. Probably something was permanently accessing your device and by rebooting you stopped the rogue process. Manytimes things like kde sound management system will tie up your sound device accidently.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  9. #9
    Just Joined! WebThingy's Avatar
    Join Date
    May 2006
    Location
    Bellingham, WA
    Posts
    69
    Ahh, good to know! If it happens again I'll know what to do.

    You rule!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •