Find the answer to your Linux question:
Results 1 to 8 of 8
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    May 2003
    Greece / Athens

    installing nvidia drivers

    i have recently tried to install the latest drivers from nvidia.i'm using an msi fx5700 128mb video card and when i install the drivers as root when i reboot the screen is flickering or sometimes is black allowing me to work only in console.i'm running suse linux 9
    what should be wrong?

  2. #2
    Linux Engineer
    Join Date
    Jul 2003
    Farnborough, UK
    Suse will install them for you if you click on the update button on the right of the kde toolbar
    Lansbury's Lido

    thekiadriver on #linuxforums - fleetingly

  3. #3
    when i did mine, it was simple, I'm runnin a MX440, but it's a generic driver, i jus went to runlevel 3(init 3)
    cd to the dir u downloaded the file 
    sh <file name> &#40;mine was for SuSE 9.0&#41;
    go thru the on screen prompts
    sax2 -m 0=nvidia
    Note: 0=nvidia, 0 is number 0 not letter o

  4. $spacer_open
  5. #4
    Just Joined!
    Join Date
    Mar 2004
    I too got a problemwhileintalling red hat 9 on a athlon 1800 proceesor computer which has a mother board with nvidia chipset.the installing reaches upto the point of installing packages and rockballs to reboot .how do i configure to install the os without ending at that give some help

  6. #5
    Linux User
    Join Date
    Jan 2003
    Cardiff, Wales

    How did you do it

    I recently did this on my fedora box. I just dropped to run level 3. and then as root ran the nvidia script which recompilied my kernel for me. then edited my XF86Config file as per the instructions and everything works like a dream.

    What were you doing when everything went tits up?
    No trees were harmed during the creation of this message. Its made from a blend of elephant tusk and dolphin meat.

  7. #6
    Not too sure what u guys are doing but this seemed to work with the distros i tried (mandrake 9.2, and RedHat 9)
    1: Change to runlevel 3 (/etc/inittab then change ur runlevel to 3 "id:5:runlevel")
    2: type in console telinit 1
    3: it should go black, and it should go into a command line thing where it says something like "sh.something"_ _ _, type exit and it should start into runlvl 3, and into a black console screen, login as root, and install the nvidia drivers, (it should be "sh ./ or something like that)
    4: startx (while in the runlvl 3)
    5: it should boot up to your X GUI (kde, blackbox, gnome, etc.)
    6: go into your XF86Config file (RedHat usrs its "/etc/X11/XF86Config". for Mandrake its "/etc/X11/XF86Config-4" file) go down to where it says load "Modules" and MAKE SURE it has this --- load "glx" ---- and make sure it DOESN'T have these ----- load "dri" ----- and this ---- load "GLcore". this and move on to step 7.
    7: go down a little more untill u get to a part where it says Section "Device", and where it says "driver" change whatever it is (should be default "nv" or "vesa") to "nvidia"
    8: change ur runlevel back to 5 (or 4 for slackware usrs, maybe even BSD usrs dont know too much about that)
    9: logout, itll send u back to the command line interface, type "telinit 5" and u should be fine!
    Unless you turned this feature off, u should see an NVIDIA logo. if this is true then u just installed the nvidia drivers.
    It took me several tries, and i had a problem with the nvidia logo filckering on and off which pissed me off, but then i figured it out EXACTLY how to do this and it works just dandy. I've installed this on a dozen comps.
    I get about 900 fps in "glxgears" in 800x600 in red hat, but a little less cause for some reason Mandrake suks all my damn reasources up.

    I have a Celeron at 2.0Ghz, 512Mbs of 3200 ram running at 266Mhz (cause when u have a Celeron it only runs at the safest speed for my motherboard) and a GeForce 2 MX 400 64Mbs.

    I hope this helps anyone here, if need more help email me at

  8. #7
    Just Joined!
    Join Date
    Mar 2004
    Piscataway, NJ
    Why was I the only one that just exited X, ran the file, and then started X again? It worked after that, NVIDIA logo and everything.

  9. #8
    Linux Newbie
    Join Date
    Feb 2003
    Swansea (UK)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts