Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I recently reinstalled Gentoo Linux on my main machine, and I've had no problems thus far, only my CPU frequency scaling seems a bit off. cpufreq-info used to say that ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer Javasnob's Avatar
    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    942

    CPU Frequency Scaling


    I recently reinstalled Gentoo Linux on my main machine, and I've had no problems thus far, only my CPU frequency scaling seems a bit off. cpufreq-info used to say that the available frequencies were from 300MHz to 2.4GHz in increments of 300 MHz, but now it reports that my hardware limits are 2.1 and 2.4GHz. Does anyone have an idea on how I can fix this?

    Thanks!
    Flies of a particular kind, i.e. time-flies, are fond of an arrow.

    Registered Linux User #408794

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Which exact CPU do you have?
    Code:
    cat /proc/cpuinfo
    Which cpufreq policy are you using?
    Code:
    cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
    And what says
    Code:
    cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    And finally which modules take care of the stepping?
    Code:
    cpufreq-info | grep driver
    Do you have anything regarding cpu power management enabled in the BIOS?
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Linux Engineer Javasnob's Avatar
    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    942
    Here's the output from the suggested commands:
    Code:
    rob@TheRing ~ $ cat /proc/cpuinfo | grep "model name"
    model name      : Intel(R) Pentium(R) 4 CPU 2.40GHz
    model name      : Intel(R) Pentium(R) 4 CPU 2.40GHz
    rob@TheRing ~ $ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor 
    ondemand
    rob@TheRing ~ $ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq 
    2100000
    rob@TheRing ~ $ cpufreq-info | grep driver
      driver: p4-clockmod
      driver: p4-clockmod
    The unusual thing is as I said: before, the minimum frequency was 300MHz; now it's 2.1GHz.

    I'll check out my BIOS to see if there's an option, but I haven't touched it since my reinstall, so I don't think that's it.

    Thanks for the help!
    Flies of a particular kind, i.e. time-flies, are fond of an arrow.

    Registered Linux User #408794

  4. #4
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    And what about the avalaible frequencies?
    Code:
    cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies
    You can force the minimal value you get out of this in scaling_min_freq.

    Also make sure the minimal frequency is not being set at boot in /etc/sysfs.conf.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  5. #5
    Linux Engineer Javasnob's Avatar
    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    942
    Code:
    rob@TheRing ~ $ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies 
    2100000 2400000
    Also, I don't have a /etc/sysfs.conf. =(
    Flies of a particular kind, i.e. time-flies, are fond of an arrow.

    Registered Linux User #408794

  6. #6
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Well that's certainly interesting.

    So you did compile the kernel yourself?
    Which one is it?

    I know you have CPU frequency enabled in the kernel and Pentium 4 clock modulation, but do you have Processor ACPI support enabled?
    Quote Originally Posted by Make menuconfig
    Power management options (ACPI, APM) --->
    ACPI (Advanced Configuration and Power Interface) Support --->
    <M> Processor
    It isn't required by "p4-clockmod", but I guess it must be useful to decode the proper CPU frequency tables.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  7. #7
    Linux Engineer Javasnob's Avatar
    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    942
    My kernel is self-compiled, and it's version 2.6.16.

    And I do have ACPI Processor support built into my kernel.
    Flies of a particular kind, i.e. time-flies, are fond of an arrow.

    Registered Linux User #408794

  8. #8
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Did you compile it with the kernel config as you had before?

    And what about :
    Code:
    cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_min_freq
    Are you using any kind of daemon for CPU management (powersaved, cpudyn,cpufreq, etc.) ?
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  9. #9
    Linux Engineer Javasnob's Avatar
    Join Date
    Jul 2005
    Location
    Wisconsin
    Posts
    942
    Yes, I simply copying my .config file over.
    Code:
    rob@TheRing ~ $ cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_min_freq
    2100000
    And no, I'm not using a daemon for CPU management.
    Flies of a particular kind, i.e. time-flies, are fond of an arrow.

    Registered Linux User #408794

  10. #10
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    So it's the same exact kernel version?

    And what about
    Code:
    dmesg | grep -i cpu
    And
    Code:
    cat /var/log/messages | grep -i cpu
    ?
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •