Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 29
I am using 32 bit Ubuntu. My xorg.conf file: Code: Section "ServerLayout" Identifier "Default Layout" Screen 0 "aticonfig-Screen[0]" 0 0 InputDevice "Generic Keyboard" InputDevice "Configured Mouse" InputDevice "stylus" "SendCoreEvents" InputDevice ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13

    I am using 32 bit Ubuntu.


    My xorg.conf file:
    Code:
    Section "ServerLayout"
    	Identifier     "Default Layout"
    	Screen      0  "aticonfig-Screen[0]" 0 0
    	InputDevice    "Generic Keyboard"
    	InputDevice    "Configured Mouse"
    	InputDevice    "stylus" "SendCoreEvents"
    	InputDevice    "cursor" "SendCoreEvents"
    	InputDevice    "eraser" "SendCoreEvents"
    EndSection
    
    Section "Files"
    
    	# path to defoma fonts
    	FontPath     "/usr/share/X11/fonts/misc"
    	FontPath     "/usr/share/X11/fonts/cyrillic"
    	FontPath     "/usr/share/X11/fonts/100dpi/:unscaled"
    	FontPath     "/usr/share/X11/fonts/75dpi/:unscaled"
    	FontPath     "/usr/share/X11/fonts/Type1"
    	FontPath     "/usr/share/X11/fonts/100dpi"
    	FontPath     "/usr/share/X11/fonts/75dpi"
    	FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection
    
    Section "Module"
    	Load  "bitmap"
    	Load  "ddc"
    	Load  "dri"
    	Load  "extmod"
    	Load  "freetype"
    	Load  "glx"
    	Load  "int10"
    	Load  "type1"
    	Load  "vbe"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Generic Keyboard"
    	Driver      "kbd"
    	Option	    "CoreKeyboard"
    	Option	    "XkbRules" "xorg"
    	Option	    "XkbModel" "pc104"
    	Option	    "XkbLayout" "us"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Configured Mouse"
    	Driver      "mouse"
    	Option	    "CorePointer"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "Protocol" "ExplorerPS/2"
    	Option	    "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
                                                          # /dev/input/event
                                                          # for USB
    	Identifier  "stylus"
    	Driver      "wacom"
    	Option	    "Device" "/dev/wacom"          # Change to 
    	Option	    "Type" "stylus"
    	Option	    "ForceDevice" "ISDV4"               # Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    
                                                          # /dev/input/event
                                                          # for USB
    	Identifier  "eraser"
    	Driver      "wacom"
    	Option	    "Device" "/dev/wacom"          # Change to 
    	Option	    "Type" "eraser"
    	Option	    "ForceDevice" "ISDV4"               # Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
    
                                                          # /dev/input/event
                                                          # for USB
    	Identifier  "cursor"
    	Driver      "wacom"
    	Option	    "Device" "/dev/wacom"          # Change to 
    	Option	    "Type" "cursor"
    	Option	    "ForceDevice" "ISDV4"               # Tablet PC ONLY
    EndSection
    
    Section "Monitor"
    	Identifier   "HP mx705"
    	HorizSync    30.0 - 70.0
    	VertRefresh  50.0 - 160.0
    	Option	    "DPMS"
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    	Identifier  "ATI Technologies, Inc. Radeon Xpress 200 (RC410)"
    	Driver      "vesa"
    	VideoRam    128000
    	Option	    "UseFBDev" "true"
    	BusID       "PCI:1:5:0"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]"
    	Driver      "fglrx"
    	Option	    "VideoOverlay" "on"
    	Option	    "OpenGLOverlay" "off"
    EndSection
    
    Section "Screen"
    	Identifier "Default Screen"
    	Device     "ATI Technologies, Inc. Radeon Xpress 200 (RC410)"
    	Monitor    "HP mx705"
    	DefaultDepth     24
    	SubSection "Display"
    		Depth     1
    		Modes    "1152x864" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth     4
    		Modes    "1152x864" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth     8
    		Modes    "1152x864" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth     15
    		Modes    "1152x864" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth     16
    		Modes    "1152x864" "1024x768" "800x600" "640x480"
    	EndSubSection
    	SubSection "Display"
    		Depth     24
    		Modes    "1152x864" "1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]"
    	Device     "aticonfig-Device[0]"
    	Monitor    "aticonfig-Monitor[0]"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Mode         0666
    EndSection

    cat /var/log/Xorg.0.log | grep -i glcore
    Code:
    (II) Loading sub module "GLcore"
    (II) LoadModule: "GLcore"
    (II) Loading /usr/lib/xorg/modules/extensions/libGLcore.so
    (II) Module GLcore: vendor="X.Org Foundation"

    Method 2 produces the same results as the other ways.

  2. #12
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Wow, your /etc/X11/xorg.conf is quite a mess.

    You might want to run
    Code:
    sudo dpkg-reconfigure xserver-xorg
    and choose "fglrx" for the driver. Then restart X.

    Quote Originally Posted by lintuxos
    cat /var/log/Xorg.0.log | grep -i glcore

    Code:
    (II) Loading sub module "GLcore" 
    (II) LoadModule: "GLcore" 
    (II) Loading /usr/lib/xorg/modules/extensions/libGLcore.so 
    (II) Module GLcore: vendor="X.Org Foundation"
    It seems the driver doesn't install right, the vendor should be something like "ATI" if I remember correctly.

    What is the output of
    Code:
    glxinfo | grep -i direct
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #13
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13
    Code:
    sudo dpkg-reconfigure xserver-xorg
    with the fglrx driver just brought up a black screen where the login should have been.

    glxinfo | grep -i direct
    Code:
    Xlib:  extension "XFree86-DRI" missing on display ":0.0".
    direct rendering: No
    OpenGL renderer string: Mesa GLX Indirect
    Sorry to be such a hassle.

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Code:
    sudo dpkg-reconfigure xserver-xorg
    should work if you answer all questions correctly.

    Try the "radeon" driver perhaps and see if it performs well for you.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  6. #15
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13
    There doesn't appear to be a "radeon" driver in sudo dpkg-reconfigure xserver-xorg

  7. #16
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by lintuxos
    There doesn't appear to be a "radeon" driver in sudo dpkg-reconfigure xserver-xorg
    Well, there should be.
    Code:
    locate radeon
    will tell you.

    Or else pick the "ati" driver, in the mean time.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  8. #17
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13
    locate radeon

    Code:
    /var/lib/dpkg/info/radeontool.md5sums
    /var/lib/dpkg/info/radeontool.list
    /var/cache/apt/archives/radeontool_1.5-3_i386.deb
    /lib/modules/2.6.12-9-386/kernel/drivers/char/drm/radeon.ko
    /lib/modules/2.6.12-9-386/kernel/drivers/video/aty/radeonfb.ko
    /lib/modules/2.6.12-10-386/kernel/drivers/char/drm/radeon.ko
    /lib/modules/2.6.12-10-386/kernel/drivers/video/aty/radeonfb.ko
    /lib/modules/2.6.15-25-386/kernel/drivers/char/drm/radeon.ko
    /lib/modules/2.6.15-25-386/kernel/drivers/video/aty/radeonfb.ko
    /usr/share/doc/radeontool
    /usr/share/doc/radeontool/changelog.Debian.gz
    /usr/share/doc/radeontool/changelog.gz
    /usr/share/doc/radeontool/lightwatch.pl
    /usr/share/doc/radeontool/README.Debian
    /usr/share/doc/radeontool/copyright
    /usr/share/man/man7/radeontool.7.gz
    /usr/share/man/man4/radeon.4.gz
    /usr/include/linux/radeonfb.h
    /usr/lib/xine/plugins/1.1.1/vidix/radeon_vid.so
    /usr/lib/xorg/modules/drivers/radeon_drv.so
    /usr/lib/dri/radeon_dri.so
    /usr/sbin/radeontool
    /usr/src/linux-headers-2.6.15-25/include/linux/radeonfb.h
    /usr/src/linux-headers-2.6.15-25/include/video/radeon.h
    /usr/src/linux-headers-2.6.15-25/include/config/drm/radeon.h
    /usr/src/linux-headers-2.6.15-25-386/include/linux/radeonfb.h
    /usr/src/linux-headers-2.6.15-25-386/include/config/drm/radeon
    /usr/src/linux-headers-2.6.15-25-386/include/config/drm/radeon/module.h
    /usr/src/linux-headers-2.6.15-25-386/include/config/fb/radeon
    /usr/src/linux-headers-2.6.15-25-386/include/config/fb/radeon/module.h
    /usr/src/linux-headers-2.6.15-25-386/include/config/fb/radeon/old.h
    /usr/src/linux-headers-2.6.15-25-386/include/config/fb/radeon/i2c.h
    /usr/src/linux-headers-2.6.15-25-386/include/config/fb/radeon/debug.h
    But
    Code:
    sudo dpkg-reconfigure xserver-xorg
    does not have a radeon option.

    ATI driver doesn't work either. Only the vesa driver has gotten me any useful results (without 3d rendering of course)

  9. #18
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Maybe
    Code:
    dpkg-reconfigure xserver-xorg
    won't allow you to choose it, but you do have the "radeon" driver.

    You can specify the driver manualy in /etc/X11/xorg.conf.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  10. #19
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13
    OK, the radeon driver works just like the vesa driver (both without direct rendering).

  11. #20
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by lintuxos
    OK, the radeon driver works just like the vesa driver (both without direct rendering).
    You can try to add those lines to your "Device" section of /etc/X11/xorg.conf :
    Code:
    Option          "RenderAccel"    "true"
    Option          "DRI"                "true"
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •