Find the answer to your Linux question:
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
I just recently bought a new PC with an ATI Radeon X200 card build in. I started with Fedora Core 5 on it and couldn't get sound or hardware acceleration ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13

    ATI Radeon X200 Problem


    I just recently bought a new PC with an ATI Radeon X200 card build in. I started with Fedora Core 5 on it and couldn't get sound or hardware acceleration working. I just installed Kubuntu (which got the sound working). Is there anyone who has had any luck getting hardware acceleration working on this card under Kubuntu (or any other distro for that matter)?

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Yes, follow those instructions to install ATI proprietary drivers :
    https://help.ubuntu.com/community/BinaryDriverHowto/ATI
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13
    Thanks for the link to the guide. I tried the methods listed, but it did not work correctly.

    The result was that things did not display properly. All open programs had clear backings, and text (if it displayed at all) would be jumbled. The screen would not refresh, so all windows that were closed would remain on the screen.

    Any further advice?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by lintuxos
    The result was that things did not display properly. All open programs had clear backings, and text (if it displayed at all) would be jumbled. The screen would not refresh, so all windows that were closed would remain on the screen.
    What says
    Code:
    cat /var/log/Xorg.0.log | grep WW
    and
    Code:
    cat /var/log/Xorg.0.log | grep EE
    about that?
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  6. #5
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13
    cat /var/log/Xorg.0.log | grep EE
    Code:
    Current Operating System: Linux ubuntu 2.6.15-25-386 #1 PREEMPT Wed Jun 14 11:25:49 UTC 2006 i686
            (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (EE) Failed to load /usr/lib/xorg/modules/extensions/libGLcore.so
    (EE) Failed to load module "GLcore" (loader failed, 7)
    (II) Loading extension MIT-SCREEN-SAVER

    cat /var/log/Xorg.0.log | grep WW
    Code:
    (WW) The directory "/usr/share/X11/fonts/cyrillic" does not exist.
    (WW) The directory "/usr/share/X11/fonts/CID" does not exist.
    (WW) `fonts.dir' not found (or not valid) in "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID".
    (WW) fglrx(0): board is an unknown third party board, chipset is supported
    (WW) fglrx(0): Specified desktop setup not supported: 8
    (WW) fglrx(0): Option "VendorName" is not used
    (WW) fglrx(0): Option "ModelName" is not used

  7. #6
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Ok, what about:
    Code:
    sudo updatedb
    (wait a few minutes for the database to build itself)

    And then
    Code:
    locate libGLcore.so
    ? Where is it?
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  8. #7
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13
    The locate command put it at:

    /usr/lib/xorg/modules/extensions/libGLcore.so

  9. #8
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Make sure you have the latest Ubuntu kernel installed?
    Code:
    sudo apt-get update
    sudo apt-get dist-upgrade
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  10. #9
    Just Joined!
    Join Date
    Jul 2006
    Posts
    13
    The kernel is completely up to date.

    It appears that I will be needing to buy a nVidia card

  11. #10
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Quote Originally Posted by lintuxos
    It appears that I will be needing to buy a nVidia card
    Hehe, we can try a few more tricks before going there.

    By the way, are you using Ubuntu 64 bits?

    And what about your /etc/X11/xorg.conf file?
    And
    Code:
    cat /var/log/Xorg.0.log | grep -i glcore
    You could try "method 2" from this page (another way to install the ATI drivers) :
    http://wiki.cchtml.com/index.php/Ubu...allation_Guide
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •