Find the answer to your Linux question:
Results 1 to 3 of 3
Okay. I'm having a couple of problems with the mice on my laptop. I'm running Ubuntu Linux 6.06 Dapper Drake. 1. I have a Synaptics touchpad built in. By default, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    4

    A couple of silly mouse problems [ONLY ONE NOW]


    Okay. I'm having a couple of problems with the mice on my laptop. I'm running Ubuntu Linux 6.06 Dapper Drake.

    1. I have a Synaptics touchpad built in. By default, it has a tap-to-click option enabled. Unfortunately, I ****ing hate tap-to-click and I want to turn it off. However, when I do turn it off (in qsynaptics) it works until I reboot, at which point it's back to tap-to-click. The funny thing is, the qsynaptics app still shows the tapping function as being turned off. Anybody know how to fix this? [EDIT: THIS ONE IS FIXED]

    2. I also have a General Electric USB mouse, which I really like, except that it has a Surprise Option Feature wherein it randomly stops working anywhere from 10-30 minutes after starting the PC. I really don't have any idea what the deal is here. Unplugging and replugging it doesn't work; I always have to restart. And it's kind of a ***** if I'm in the middle of an online game of Cube.

  2. #2
    Just Joined!
    Join Date
    Jul 2006
    Posts
    4
    Here's my xorg.conf file, if it helps:

    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen 0 "aticonfig-Screen[0]" 0 0
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    InputDevice "stylus" "SendCoreEvents"
    InputDevice "cursor" "SendCoreEvents"
    InputDevice "eraser" "SendCoreEvents"
    InputDevice "Synaptics Touchpad"
    EndSection

    Section "Files"

    # path to defoma fonts
    FontPath "/usr/share/X11/fonts/misc"
    FontPath "/usr/share/X11/fonts/cyrillic"
    FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/share/X11/fonts/Type1"
    FontPath "/usr/share/X11/fonts/100dpi"
    FontPath "/usr/share/X11/fonts/75dpi"
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection

    Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "type1"
    Load "vbe"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc104"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ExplorerPS/2"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "true"
    EndSection

    Section "InputDevice"
    Identifier "Synaptics Touchpad"
    Driver "synaptics"
    Option "SHMConfig" "on"
    Option "SendCoreEvents" "true"
    Option "Device" "/dev/psaux"
    Option "Protocol" "auto-dev"
    Option "HorizScrollDelta" "0"
    EndSection

    Section "InputDevice"

    # /dev/input/event
    # for USB
    Identifier "stylus"
    Driver "wacom"
    Option "Device" "/dev/wacom" # Change to
    Option "Type" "stylus"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"

    # /dev/input/event
    # for USB
    Identifier "eraser"
    Driver "wacom"
    Option "Device" "/dev/wacom" # Change to
    Option "Type" "eraser"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "InputDevice"

    # /dev/input/event
    # for USB
    Identifier "cursor"
    Driver "wacom"
    Option "Device" "/dev/wacom" # Change to
    Option "Type" "cursor"
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    EndSection

    Section "Monitor"
    Identifier "Generic Monitor"
    Option "DPMS"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "ATI Technologies, Inc. Radeon Xpress 200M (RC410)"
    Driver "ati"
    BusID "PCI:1:5:0"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]"
    Driver "fglrx"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "ATI Technologies, Inc. Radeon Xpress 200M (RC410)"
    Monitor "Generic Monitor"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "1024x768"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1024x768"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1024x768"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1024x768"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1024x768"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1024x768"
    EndSubSection
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]"
    Device "aticonfig-Device[0]"
    Monitor "aticonfig-Monitor[0]"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

  3. #3
    Just Joined!
    Join Date
    Jul 2006
    Posts
    4
    Fixed the first problem. Still haven't the foggiest about the second.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •