Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, earlier this week I made the decision to finally switch to Linux. I just completed an installation of Ubuntu's most recent version. I downloaded the LiveCD and installed it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    1

    Question Unable to detect PCI devices


    Hi, earlier this week I made the decision to finally switch to Linux. I just completed an installation of Ubuntu's most recent version. I downloaded the LiveCD and installed it without any real problems.

    I'm discovering now though that none of my PCI cards or USB devices are being detected by the system. I have a built in ethernet card and a wireless PCI network card, neither of which are detected by the system. Additionally, when I insert my USB flash disk, nothing happens. My graphics card seems to function fine however (its an AGP card).

    When I enter lspci in the terminal, it just goes straight to the next line - no real response. Same goes for lsusb. Also, when I type sudo lshw, it displays info about my CPU, HD and cd drives but no enteries are listed for usb or pci. It does, however, list my CPU as a Micro-Star International MS-6366 (not sure if thats helpful).

    Here are some of the dmesg return, which I hope will be helpful to someone in order to debug my problem:

    PnPBios: Disabled by ACPI PNP
    PCI: Using ACPI for IRQ routing

    PCI: Bridge: 0000:00:01.0
    IO window: disabled
    MEM window: dc000000-ddffffff
    PREFETCH window: dc000000-ddffffff

    "pci=routeirq"

    isapnp: No Plug & Play device found
    Also, when I start up the computer it tries to load up my PCMCIA drivers, but it says PCMCIA not present - again, not sure if that helps.

    I really appreciate anyone's help. I would really like to get my system working, but if I can't find a solution soon I will have to return to Windows

    Thanks!

  2. #2
    Just Joined!
    Join Date
    Nov 2005
    Location
    Auburn, Maine
    Posts
    75
    As you will soon find out, not all hardware is supported by Linux. If everything in your computer is stock (except obviously the Linux OS, which you installed yourself) then it was all made assuming you would be using Windows (another sucky thing about Microsoft is they are greedy and want all hardware to work for them and them only). Fortunatly there is a nice little website called http://www.linuxcompatible.org and they have a list of all kinds of devices that you can use with linux.

    Before going out and getting new devices though, make sure that the devices you are using dont provide drivers for Linux. Go to the driver section in the manufacturers website and look for downloads for Linux. Optionally, you could also search google for linux drivers for your particular devices if they arent supplied by the manufacturer's website. If all else fails, go to linuxcompatible.org and find out a linux friendly substitute for your devices.

    Hope this helps

  3. #3
    Just Joined!
    Join Date
    May 2006
    Location
    Great Barrier Reef -QLD-Australia on a boat
    Posts
    24
    get the Sept 2006 edition of Linux Magazine
    It has a DVD of Knoppix 5.0
    Use it as a live CD ie boot from the DVD and see what it detects
    It may well get them all as Ubuntu is notorious for not getting them!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2006
    Posts
    22
    Hi

    I had exactly the same problem with Ubuntu when I tried to install it. I got no output from lspci either. I tried a lot of things - here's a thread I started on another forum which lists most of it: http://www.linuxquestions.org/questi...d.php?t=463397

    And an earlier one in a hardware forum about the same problem but before I realised I wasn't getting any lspci output:
    http://www.linuxquestions.org/questi...d.php?t=463119

    I just thought I'd post them incase anything there helps you.

    In the end I had to give up, but maybe you'll get somewhere. If so I'd love to know what was going on.

    I've just installed SUSE, and my hardware seems to be detected okay (printer and scanner at least), though I'm having other problems...
    It was a pleasant surprise to see something from lsusb though!
    So maybe try a different distro if it starts proving too awkward?

    Good luck

    Xenny

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •