Find the answer to your Linux question:
Results 1 to 8 of 8
hi, I changed my Monitor from 14-inch to 15-inch on my FC4 Linux install. I normally boot up on Runlevel-3 and use the GUI only if I have to. Yes, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Nov 2004
    Posts
    167

    Changed my Monitor, startx - GUI stopped working


    hi,

    I changed my Monitor from 14-inch to 15-inch on my FC4 Linux install. I normally boot up on Runlevel-3 and use the GUI only if I have to. Yes, my PC boots up normally, no error, its only that the command

    Code:
    start x
    now results in this error

    .....
    II Unloading module.....
    .
    .
    (EE) screens found, but none has a usable config
    .
    .
    fatal server error
    no screens found
    pls consult the xorg foundation for support
    NOTE: i use the 800x600 resolution on my 14-inch monitor. The monitor isnt listed in the Monitor hardware type list, but its the monitor i used initial-during installation. The present setting is "Generic CRT display", with color-depth as "millions of colors".

    pls how can i modify the X-configs, what and what do I change/where so as to use my new 15-inch monitor.

    Tokunbo

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    You probably need to edit your /etc/X11/xorg.conf file and update the horizontal and vertical refresh rates for your new monitor. You can use vim, nano, pico, or some other editor from the command line, and you'll need to be root to edit that file.
    oz

  3. #3
    Linux Newbie
    Join Date
    Nov 2004
    Posts
    167
    yeah ozar,

    thats exactly what i did. the present config: 800x600, 14" monitor, Monitor type isnt listed in the hardware list, so the present setting is "Generic CRT display with color depth = millions of colors.

    the hor sync/vertical refresh are 31.5 - 37.9 / 50.0 - 70.0

    these (above) are the configs working on the 14".

    SO yes, i delve into the /etc/X11/xorg.conf file and changed the hor sync/vertical refresh to the settings of my new 15" monitor(30-50 / 50-150) respectively....based on the labels on the monitor. I saved the file, rebooted, etc, but still when I try to startx, i still get the same error as before. is there any other place to edit something?

  4. #4
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Go here, and look at item #7(2) *Message: "Screen(s) found, but none have a usable configuration:

    http://wiki.x.org/wiki/FAQErrorMessages

    What is the make and model of the monitor are you using?
    oz

  5. #5
    Just Joined!
    Join Date
    May 2006
    Location
    Great Barrier Reef -QLD-Australia on a boat
    Posts
    24
    Just as an aside keep in mind some motherboards use shared memory. Mine worked ok on 8 Meg but my new monitor would not run on that and I had to increase it to 12.

  6. #6
    Linux Newbie
    Join Date
    Nov 2004
    Posts
    167
    ok, thanks guys

    ill give your suggestions a try

  7. #7
    Just Joined!
    Join Date
    Aug 2006
    Posts
    3
    The truth is Linux is very hardware concious.
    I had the same problem when i changed my mouse,can't really remeber what i did but i think i used kudzu or ... Give a minute to check ,i will be right back

  8. #8
    Just Joined!
    Join Date
    Aug 2006
    Posts
    3
    This is 2006 and you probably have found the answer to your question but for other people that may find themselves in the same situation.

    Like i said earlier,my Linux didn't detect my new mouse,so i moved to run level 1 (by typing in init 1) typed kudzu at command prompt and rebooted.

    Then a screen comes up telling you about the configuration-whether to discard,acccept or ignore the configuration.

    Then you accept and all your problems are solved!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •