Find the answer to your Linux question:
Results 1 to 2 of 2
Dear mouse users, I know I'm not the first by far, who is talking about that topic. Unfortunately none of the concerning forum entries did help. I recently bought a ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    1

    Suse doesn't scroll horizontal!


    Dear mouse users,

    I know I'm not the first by far, who is talking about that topic. Unfortunately none of the concerning forum entries did help. I recently bought a mouse which (to crown it all??) was not produced by either Microsoft or Logitech. The ?Corporation? is called 'Bazoo' and is supposed to be a ?subsidiary? of Vivanco.
    It is an optical usb-mouse, consisting of 6 buttons and a wheel that shall be able scrolling both vertically and horizontally. I can do whatever I want, it doesn't scroll left and right.

    Information:

    OSS: Suse Linux 10.1
    Kernel: 2.6.16.13-4-smp
    Xorg: 6.9.0

    Doing 'cat /proc/bus/input/devices' returns the following data about the mouse:
    I: Bus=0003 Vendor=04b4 Product=6370 Version=0100
    N: Name="Dexin Corp. Optical Mouse "
    P: Phys=usb-0000:00:10.1-1/input0
    S: Sysfs=/class/input/input4
    H: Handlers=mouse0 event3
    B: EV=7
    B: KEY=1f0000 0 0 0 0 0 0 0 0
    B: REL=103

    Moreover I found a little c-script on a tutorial site (http://www.linux-gamers.net/modules/...Mouse+Buttons), that tries to explain how to configure a mouse successfully by using the 'evdev' protocol/ driver. In some way the script examines the desired input device and leads to the following information about my mouse:

    command: ./evdev-key-btn-test /dev/input/event3

    output:
    Supported Keys:
    Key 0x110 (Left Button)
    Key 0x111 (Right Button)
    Key 0x112 (Middle Button)
    Key 0x113 (Side Button)
    Key 0x114 (Extra Button)
    Buttons/Keys: 5

    Supported Relative axes:
    Relative axis 0x00 (X Axis)
    Relative axis 0x01 (Y Axis)
    Relative axis 0x08 (Vertical Wheel)

    'evdev' seems not to be working on my computer. I'm gonna tell a few things about that. First I want to tell from the 'xev' results.
    The three main buttons on the front are normally identified as 1, 2, 3. And so is the wheel (scrolling up and down corresponds to 4 and 5). If I try scrolling left or right there's no reaction at all. I get the same result using the button on top of the mouse. What is left are the two thumb buttons on the side of the mouse that are (I can hardly believe it!) identified as 8 and 9.
    Is that supposed to mean there are some more buttons 6, 7 and 10 probably that just don't work by now?

    Concerning 'evdev':
    At first I read that evdev is to be included in xorg 6.9.0 already. Then I read that it will be in the xorg 7.0 release for the first time. What is true?
    Nonetheless I can find data here that are called 'evdev_drv.so', 'evdev_drv.o', 'evdev.c' and the like. But it didn't work. I than installed the 'x11-input-evdev' package (I guess that was the name). But it still doesn't work. Whenever I use evdev as protocol in the xorg.conf, I can find an error message in my Xorg.0.log that says "unknown protocol evdev" and X-Server won't start because it can't find a well defined mouse.

    I just read that the other protocols (explorerps/2 and the like) support a maximum of 7 buttons. Is that true? And are the 2 (or 4) events caused by the wheel to be included in that 7?
    What can I do with my as 8 and 9 defined buttons?
    What is the exact status of 'xev'? Can I expect that buttons which are not recognized by xev by now will never work (like the horizontal scrolling) or is it just a matter of configuration?


    My actual mouse entry in the xorg.conf:
    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "ButtonNumber" "9" #in fact that should be 10
    Option "Buttons" "9" #in fact that should be 10
    Option "Device" "/dev/input/mice"
    Option "Name" "Dexin Corp. Optical Mouse"
    Option "Protocol" "explorerps/2"
    Option "Dev Phys" "usb-0000:00:10.1-1/input0
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5 6 7"
    EndSection

    By now I've been trying several modifications, partly concerning a mod. of the xmodmap as well. But nothing did work. I tried different protocols, different ZAxisMapping, different ButtonNumbers.


    Can anyone tell me wether or not there will ever be a theoretical chance that one day my wheel will be able to scroll in any direction?

    Thanks a lot for your effort, Layne

  2. #2
    Just Joined!
    Join Date
    Oct 2006
    Posts
    1

    evdev for SuSE 10.1

    check out this link:

    http://katze-mit-wut.azundris.com/ar...and-x.org.html

    On SuSE evdev is a Driver, not a Protocol: here is my xorg.conf

    Section "InputDevice"
    Identifier "Mouse[1]"
    Driver "evdev"
    Option "Buttons" "9"
    Option "Dev Name" "Logitech USB RECEIVER"
    Option "Dev Phys" "usb-0000:00:10.0-2/input0"
    Option "Device" "/dev/input/event2"
    Option "ZAxisMapping" "4 5"
    EndSection

    This works on my machine running stock SuSE 10.1 with a Logitech LX7

    Cheers,

    Alberto.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •