Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11

    Quote Originally Posted by Dolda2000
    Like I just said, no 2.4 kernel has drivers for the audigy. Check out that link I gave instead.
    I've downloaded the Emu10k1-drivers, but there's something wrong when I'm trying to install the drivers.
    What should the KERNEL_SOURCE directory be set to?
    (default is "/lib/modules/`uname -r`/build")

    When trying to install, I get the error:
    Code:
    [root@localhost emu10k1-v0.20a]# make
    make -Cscripts
    make[1]: Entering directory `/home/emanuel/dwnld/drvrs/emu10k1-v0.20a/scripts'
     
    /lib/modules/2.4.20-30.9/build directory does not exist. Please edit the file 'config'
    in this directory and set KERNEL_SOURCE to the correct location of your
    kernel source.
     
    You are currently running kernel version 2.4.20-30.9, the source code should
    be for this version.
     
    make[1]: *** [get_version] Error 1
    make[1]: Leaving directory `/home/emanuel/dwnld/drvrs/emu10k1-v0.20a/scripts'
    make: *** [opts] Error 2
    I set "KERNEL_SOURCE :=/lib/modules/`uname -r`/build" to "KERNEL_SOURCE :=/lib/modules/`uname -r`/", but instead I get:
    Code:
    [root@localhost emu10k1-v0.20a]# make
    make -Cscripts
    make[1]: Entering directory `/home/emanuel/dwnld/drvrs/emu10k1-v0.20a/scripts'
    /lib/modules/2.4.20-30.9//include/linux/version.h is missing. Please run make config
    in your kernel source tree
    make[1]: *** [get_version] Error 1
    make[1]: Leaving directory `/home/emanuel/dwnld/drvrs/emu10k1-v0.20a/scripts'
    make: *** [opts] Error 2
    When I try to search after the file named "version.h" it's found in "/usr/include/linux" and in "/usr/include/sp/lib".

    I try by setting "KERNEL_SOURCE" to "KERNEL_SOURCE :=/usr".
    The error message then becomest:
    Code:
    [root@localhost emu10k1-v0.20a]# make
    make -Cscripts
    make[1]: Entering directory `/home/emanuel/dwnld/drvrs/emu10k1-v0.20a/scripts'
    cc -I/usr/include get_version.c -o get_version
    make[1]: cc: Command not found
    make[1]: *** [get_version] Error 127
    make[1]: Leaving directory `/home/emanuel/dwnld/drvrs/emu10k1-v0.20a/scripts'
    make: *** [opts] Error 2
    What shall I set KERNEL_SOURCE to? Or is it anyting else that might be wrong?

    Simply, what shall I do to make the drivers installing correctly?

  2. #12
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It seems that you don't have your kernel source code installed. You'll have to install it from the distro CDs to be able to compile modules.

  3. #13
    Quote Originally Posted by Dolda2000
    It seems that you don't have your kernel source code installed. You'll have to install it from the distro CDs to be able to compile modules.
    Ok. The only problem is while trying to install the source code. I get an error message that says I can't install, because i don't have krb5-libs in version 1.2.10 and version 0.9.7a-2 of openssl. I just can't understand this - I've already got a newer version of krb5-libs and the mentioned version of openssl.

    Can I find the source code on Red Hats homepage or something like that?

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    That's real strange - the kernel source code shouldn't require either krb5-libs or openssl to begin with. Are you absolutely sure that you're attempting to install the right package?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •