Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
In the 2.4 kernel, using XawTV was easy. The device file used by default, /dev/video0, worked perfectly. Now in 2.6.3, that file suddenly doesn't work. I have a bt878 card, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Location
    Piscataway, NJ
    Posts
    27

    /dev/video0


    In the 2.4 kernel, using XawTV was easy. The device file used by default, /dev/video0, worked perfectly. Now in 2.6.3, that file suddenly doesn't work. I have a bt878 card, and the video4linux and video4linux2 module is loaded into my kernel. My question is, did the video device files change in 2.6? Which am I supposed to be using to watch TV with XawTV?

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I have no problems watching TV from my BT878 card with a 2.6.3 kernel. What kind of error/abnormal behavior do you get?

  3. #3
    Just Joined!
    Join Date
    Mar 2004
    Location
    Piscataway, NJ
    Posts
    27
    If I run XawTV with no command line options I get a blue screen. Before installing the new kernel, it ran fine. If I run

    xawtv -c /dev/video0

    (which is the default right?) it says:

    can't open /dev/video0: No such device
    v4l-conf had some trouble, trying to continue anyway
    v4l2: open /dev/video0: No such device
    v4l2: open /dev/video0: No such device
    v4l: open /dev/video0: No such device
    no video grabber device available

    Configuration options (~/.xawtv) haven't changed since I had kernel 2.4.22 running.

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Check so that the appropriate modules are loaded. You will at the least need to have the bttv module loaded, and it in turn should have loaded some other modules such as the tuner module, usually the msp3400 module and maybe some more.

    A blue screen... I read bluescreen at first. =)

  5. #5
    Just Joined!
    Join Date
    Mar 2004
    Location
    Piscataway, NJ
    Posts
    27
    Hey thanks man. I just did a modprobe bttv and it worked right after. I appreciate your help.

  6. #6
    Just Joined!
    Join Date
    Mar 2004
    Location
    Piscataway, NJ
    Posts
    27
    Ok, now I thought I could figure out the sound all by myself...

    I'm using ALSA of course. No "real" OSS support (besides the built in OSS compatibility which works well). I used:

    -C /dev/dsp
    -C /dev/adsp
    -C /dev/sound

    some others I don't remember and I left it alone too, and the channels are all mute. I made sure the mute setting from within XawTV isn't on and other operating system sounds work. Is there a different device file I'm supposed to be using?

    EDIT: I can actually hear sound REAL quiet. I can't exactly just crank the sound though because everything else will be too loud. I decided to stick with /dev/adsp and mess with the alsamixer settings. I turned everything up and it's still too quiet to hear...

  7. #7
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    There are usually two "volume knobs". There is partly the sound card mixer, but the TV card often has a volume setting of its own. Try the numpad +/- keys in xawtv and see if it makes a difference.

  8. #8
    Just Joined!
    Join Date
    Mar 2004
    Location
    Piscataway, NJ
    Posts
    27
    No, it has no difference. You just use the default device files right?

  9. #9
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Yeah, that's right. Can you post the dmesgs that the kernel gives right after your probe the bttv module?

  10. #10
    Just Joined!
    Join Date
    Mar 2004
    Location
    Piscataway, NJ
    Posts
    27
    This is gonna sound really stupid, but where are the dmesgs printed? In other words:

    [root@localhost dwayne]# modprobe bttv
    [root@localhost dwayne]#

    is what happens. This looks pretty bad though...

    [root@localhost dwayne]# modprobe btaudio
    FATAL: Module btaudio not found.
    [root@localhost dwayne]#

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •