Find the answer to your Linux question:
Results 1 to 10 of 10
I just realized this was a problem after about a month of installing Mandriva on my computer. I have 2.5GB of RAM, 2 X 1GB sticks and 2 X 256MB ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    11

    Mandriva does not recognize all available memory


    I just realized this was a problem after about a month of installing Mandriva on my computer. I have 2.5GB of RAM, 2 X 1GB sticks and 2 X 256MB sticks. BIOS shows me 2.5gigs (2560MB) as available memory, perfectly. But Mandriva for some reason only sees 256MB. I found some sites that suggested hardcoding "mem=xxxM" into the linux entry of the grub.conf (in my case menu.lst) file if you know how much memory your system really has - in my case 2.5GB. So I tried that and now my linux entry in the menu.lst file reads:

    title linux
    kernel (hd0,0)/boot/vmlinuz root=/dev/hda1 resume=/dev/hda5
    splash=silent vga=788 mem=2560M
    initrd (hd0,0)/boot/initrd.img

    I restarted. No luck. Linux still sees my memory as 256MB. Please help! Some other suggestions online pointed to having to recompile the kernel!

  2. #2
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    I haven't used it, but Memtest86 is a stand-alone memory diagnostic CD that you download, burn, and boot.

    I'm wondering if the timing on some of your memory is marginal enough that the Linux startup code rejects it. The memory test might be able to tell you that. Sometimes BIOS has parameters you can tweak to slowdown access to memory and therefore make it more reliable.

    Also, you probably already looked, but if not, run 'dmesg' (or look at /var/log/dmesg) to see if it says why it rejected any of your memory.

  3. #3
    Linux User Kojak's Avatar
    Join Date
    Apr 2006
    Posts
    421
    Do you have the correct kernel installed? There are special kernels for high memory machines, marked "up-4GB"

    kernel-2.6.12-24mdk-i686-up-4GB
    Windows free since 2002 | computing since 1984

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Aug 2006
    Posts
    5

    Newbie

    How do i get started here with a new Thread?
    thanks

  6. #5
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    hi ram1234 !!

    Quote Originally Posted by ram1234
    How do i get started here with a new Thread?
    thanks
    click on link GNU Linux Zone and then on New Thread button ( top left )

    <=== { casper } ===>
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #6
    Just Joined!
    Join Date
    Jul 2006
    Posts
    11
    Quote Originally Posted by Kojak
    Do you have the correct kernel installed? There are special kernels for high memory machines, marked "up-4GB"

    kernel-2.6.12-24mdk-i686-up-4GB
    Sorry if I sound like a total newbie, coz I am!... but how do I determine what kernel I have installed? I'm not sure if I have the kernel that you have mentioned. If I need to install the new kernel that you have mentioned, how should I go about doing it? I just downloaded the Mandriva CD images 1, 2 and 3 from the one of the mirrors through the mandriva website.

  8. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    hi vinkrish !!!

    on terminal type this command and post the output here......

    $ uname -a
    this will give you the Kernel name......

    <=== { casper } ===>
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #8
    Linux User Kojak's Avatar
    Join Date
    Apr 2006
    Posts
    421
    uname -a or uname -r will show you that you probably use the default kernel, which works well for machines with less than 1 GB RAM. For obtaining the up-4GB kernel, go to the easyurpmi site: http://easyurpmi.zarb.org/?language=en

    Set up mirrors as explained there. Once this is done, open the MCC, aka. "Configure your computer", go to the software install section, select "show all packages" and select the up-4GB kernel for installation.
    Windows free since 2002 | computing since 1984

  10. #9
    Just Joined!
    Join Date
    Jul 2006
    Posts
    11
    The issue remains. It still recognizes 256MB RAM only. I set up mirrors from the easyurpmi site. I installed the new kernel 12-24mdk-i686-up-4GB and I now have 3 new entries in my /boot/grub/menu.lst file besides the original 3 (linux, nonfb and failsafe). They are as follows

    title linux-i686-up-4GB
    kernel (hd0,0)/boot/vmlinuz-i686-up-4GB root=/dev/hda1 resume=/dev/hda5
    initrd (hd0,0)/boot/initrd-i686-up-4GB.img

    title 2612i686up4G-12
    kernel (hd0,0)/boot/vmlinuz-2.6.12-12mdk-i686-up-4GB root=/dev/hda1 resume=/dev/
    hda5
    initrd (hd0,0)/boot/initrd-2.6.12-12mdk-i686-up-4GB.img

    title 2612i686up4G-24
    kernel (hd0,0)/boot/vmlinuz-2.6.12-24mdk-i686-up-4GB root=/dev/hda1 resume=/dev/
    hda5
    initrd (hd0,0)/boot/initrd-2.6.12-24mdk-i686-up-4GB.img

    I tried booting up through all three of them. I still don't see my RAM upped to 2.5GB as it is supposed to be. Please help.
    Two questions:
    1. Why are there and what is the difference between between the 3 new entries? (linux-i686-up-4GB, 2612i686up4G-12 and 2612i686up4G-24).
    2. Should I try appending mem=2560M at the end of the "kernel (hd0,0)" line of any of these 3 new entries? If so which one? I read this solution posted on a page http://www.webmo.net/support/linux_memory.html

  11. #10
    Linux Enthusiast KenJackson's Avatar
    Join Date
    Jun 2006
    Location
    Maryland, USA
    Posts
    510
    vmlinuz-2.6.12-24mdk-i686-up-4GB is the same as
    vmlinuz-2.6.12-12mdk-i686-up-4GB, but it's a later release.
    Later is usually better because it includes more bug fixes and more features, etc.

    vmlinuz-i686-up-4GB is probably a symbolic link for the last one installed.
    If you run "ls -l /boot/vml* ", you will see. This entry is no different than the one it points to.

    I would definitely try the "mem=2560M" parameter, and maybe "mem=2.5G". I have no other ideas.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •