Find the answer to your Linux question:
Results 1 to 4 of 4
I bought a USB hard disk (usb 1.1) and put 2 partitions on it. I mounted both partitions flawlessly. However, partition 1 is mounted with read and write access to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Posts
    1

    read only error


    I bought a USB hard disk (usb 1.1) and put 2 partitions on it. I mounted both partitions flawlessly. However, partition 1 is mounted with read and write access to all users. When i try to change access of partition 2 i get an error that says 'cannot change permissions to a read only disk'.

    To the best of my knowledge, i never made partition 2 read only. How can i get around this and give access to all users?

  2. #2
    Linux User
    Join Date
    Nov 2003
    Location
    Brooklyn, NY
    Posts
    347
    Try adding users to 'usb' group.

  3. #3
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    How are you mounting it?

  4. #4
    Just Joined!
    Join Date
    Sep 2004
    Posts
    2
    I had the same error with a normal vfat-partition of mine. whatever i did and however i mounted it, I could sometimes touch my data on the partition one time and then there was this read-only system error.

    I did a filesystem-check then and there were hundreds of cluster-errors which were corrected. After I made this, I could work with the partition about 2 days and then there was the same error again.
    I deleted the partitions now and made new ones, so it's maybe a hardware error

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •