Find the answer to your Linux question:
Results 1 to 9 of 9
I created a usb directory in /mnt , then I ran the command mount /dev/sda1 /mnt/usb I get a error message saying "mount: /dev/sda1 is not a valid block device". ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! asif2k's Avatar
    Join Date
    Feb 2006
    Location
    TEXAS
    Posts
    59

    cannot mount usb drive


    I created a usb directory in /mnt , then I ran the command

    mount /dev/sda1 /mnt/usb
    I get a error message saying "mount: /dev/sda1 is not a valid block device".

    My usb is LexarMedia (512MB).

    I am running Fedora Core. The /dev/sda1 does not exist. I ran the command
    dmesg|grep -i usb
    result:
    usbcore: registered new driver usbfs
    usbcore: registered new driver hub
    usbcore: registered new driver hiddev
    usbcore: registered new driver hid
    drivers/usb/input/hid-core.c: v2.0:USB HID core driver
    Is there something I am doing wrong? Can someone help me with this. Your help is appreciated.

    thanks in advance

  2. #2
    Just Joined!
    Join Date
    Sep 2006
    Posts
    6
    I have used several USB thumb drives, including at least 8 from Lexar. Most, but not all, worked under Linux (not always automounting), all worked under various versions of the worlds most popular operating system. However:

    A Lexar Traveler did not work under Linux. This drive contains features to synchronize data when moving between multiple Windows systems. A call to Lexar engineering determined that this drive has firmware features which prevents it from working on Linux.

    128 & 256 mb Lexar Jump Drive Secure drives work fine on SUSE 9.x, 10.0 & 10.1.

    A 512 mb Jump Drive Secure drive does not work on SUSe10.0. The YAST hardware information service can't find it, nor can the USB monitor. I got similar "not valid device" messages. I just checked and it automounts on my wife's SUSE 10.1.
    Since these are inexpensive devices, I think the intellectually unsatisfactory but practical answer is that there are hidden incompatabilities and some just don't work. Try another.

  3. #3
    Linux Newbie
    Join Date
    Nov 2003
    Location
    Maryland
    Posts
    105
    post the output of:

    ls /dev/sd*

    the device may NOT be on sda1, but perhaps sb1, etc.

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi asif2k !!!

    By default, Red Hat loads usb-uhci and usbcore on startup. But you'll need to load an additional module called usb-storage in order to get a flash drive working. To do this, simply type:

    $ modprobe usb-storage

    create a mount point
    $ mkdir /mnt/usbstick

    add this line in fstab file.....

    /dev/sda1 /mnt/usbstick vfat user,noauto,umask=0 0 0

    $ mount /mnt/usbstick



    ... casper ...
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined! asif2k's Avatar
    Join Date
    Feb 2006
    Location
    TEXAS
    Posts
    59
    I added the line in the fstab file as you instructed. Well, that does not do the trick. Again, it is still giving me the same message.

    mount: /dev/sda1 is not a valid block device
    probably not compatible with Fedora Core.

  6. #6
    Just Joined! asif2k's Avatar
    Join Date
    Feb 2006
    Location
    TEXAS
    Posts
    59
    Quote Originally Posted by aimstolemylife
    post the output of:

    ls /dev/sd*

    the device may NOT be on sda1, but perhaps sb1, etc.
    the output this command is too long.

  7. #7
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Hi !!

    did you load usb-storage module using modprobe ???

    $ modprobe usb-storage

    unplug USB device... plug again and type this command

    $ tail -s 3 -f /var/log/messages

    check the device name kernel assigned to your USB device
    this is output on my machine

    Sept 1 17:06:09 localhost kernel: hub.c: new USB device 00:1f.2-1, assigned address 4
    Sept 1 17:06:13 localhost /etc/hotplug/usb.agent: Setup usb-storage for USB product d7d/100/100
    Sept 1 17:06:13 localhost /etc/hotplug/usb.agent: Setup nomadjukebox for USB product d7d/100/100
    Sept 1 17:06:13 localhost /etc/hotplug/usb.agent: Module setup nomadjukebox for USB product d7d/100/100
    Sept 1 17:06:13 localhost kernel: SCSI device sda: 121856 512-byte hdwr sectors (62 MB) Sept 1 17:06:13 localhost kernel: sda: Write Protect is off
    Sept 1 17:06:13 localhost kernel: sda: sda1 Sept 1 17:06:13 localhost devlabel: devlabel service started/restarted
    mount usb device using that name......


    .... casper ....
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  8. #8
    Just Joined!
    Join Date
    Jun 2006
    Posts
    74
    Quote Originally Posted by devils_casper
    Hi asif2k !!!

    By default, Red Hat loads usb-uhci and usbcore on startup. But you'll need to load an additional module called usb-storage in order to get a flash drive working. To do this, simply type:

    $ modprobe usb-storage

    create a mount point
    $ mkdir /mnt/usbstick

    add this line in fstab file.....

    /dev/sda1 /mnt/usbstick vfat user,noauto,umask=0 0 0

    $ mount /mnt/usbstick



    ... casper ...

    Dear Casper,

    Great man, command "/dev/sda1 /mnt/usbstick vfat user,noauto,umask=0 0 0" works for me and now i am able to load my USB drive, uptil and until i was not able to do so, this thing saves my lot of cds, because instead of that i was writing the CDs, and i could not found any option which allows my cds to write than once, so i have to write the cds, only once for either 3 Mbs or 14 Kbs, or even i could not my PC to set it up in the windows domain, do you know any of these options?

    Thanks,
    Nishant

  9. #9
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    HI Nishant !!

    for CDs....
    ( i am in windows box right now and dont remember K3b option )
    in Nero you can do this......

    before burning CD, check the "Allow files to be added later (multisession disc)" check box and second checkbox "Verify data on disk after burning" should be unchecked..... these checkboxes are in CD name assigning dialog box....

    for windows domain... what type of network you have ????
    you should start a new thread for this problem so that other members can look in... this thread's title
    is different than your problem......



    .... casper ....
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •