Find the answer to your Linux question:
Results 1 to 3 of 3
I'm upgrading from a 2.6.1 kernel to 2.6.3 The kernel build went OK, but I must have missed the documentation that says that libata calls an SATA drive '/dev/sda' whereas ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Location
    New Mexico, USA
    Posts
    3

    SATA drive - 2.6.3 kernel upgrade


    I'm upgrading from a 2.6.1 kernel to 2.6.3 The kernel build went OK, but I must have missed the documentation that says that libata calls an SATA drive '/dev/sda' whereas it used to be '/dev/hde'.
    I installed an old ATA drive (/dev/hda) and have booted a 2.6.3 kernel from the ATA drive. I can mount the SATA partitions in fstab (/dev/sda?) except for '/' which has the /dev/hda partition.
    I can mount the SATA '/' partition elsewhere and it appears to be intact.
    When I run lilo is says 'Warning: /dev/sda is not on the first disk'.
    If I boot from the SATA it panics saying 'Kernel Panic: VFS: Unable to mount root fs on unknown-block (8,7)
    In desperation I tried to 'rdev /dev/sda7 /dev/sda7', no difference.
    I haven't had any success with a boot / rescue floppy either.
    This system has worked great with the 2.6.1 kernel, but now that won't boot from the SATA drive either.
    How do I make it boot from /dev/sda7 ?
    OS = Debian Woody (testing)

  2. #2
    Linux Newbie robak's Avatar
    Join Date
    Jan 2004
    Posts
    136
    maybe you forgot to buildin your sata controller into your kernel.

    search in the kernel-config under
    device drivers -> ATA/ATAPI/MFM/RLL support.
    and dont forget to compile the devFS into the kernel, though the 2.6 kernels work with sysFS but i think debian and gentoo still need devFS
    make install not love

    Registered Linux user number 369245

  3. #3
    Just Joined!
    Join Date
    May 2004
    Location
    Dordrecht, the Netherlands
    Posts
    4

    like you said, it's /dev/sda now

    in lilo (or grub), you need to specify the root. When you install it, the disk is /dev/hde7, when booting it is /dev/sda7.

    so in lilo, type (type shift or control to get to the prompt when seeing the lilo message:
    vmlinuz root=/dev/sda7
    of course, vmlinuz may be another kernel image, but the gist should be clear.

    when booted, edit the lilo.conf and fstab to match the new /dev structure. Of course, that means that going back to an older kernel is not easily possible.

    In grub, there may be a problem accessing the sata drive, otherwise, go along the the lines above. I reccommend to use the older net install (bf2.4) and use debian unstable. That uses lilo by default, and is less frickle than testing.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •