Find the answer to your Linux question:
Results 1 to 2 of 2
I've an old MSI matx motherboard, with a slot A athlon (it's that old). I've added a HighPoint single IDE connecter PCI IDE card to it (to support my large ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    2

    Problems trying to use hpt371 driver


    I've an old MSI matx motherboard, with a slot A athlon (it's that old). I've added a HighPoint single IDE connecter PCI IDE card to it (to support my large disks). I'm running RedHat 7.3 .

    I downloaded the driver from the HighPoint site and went through the test stage

    insmod hpt371.o and that worked fine.

    So I then followed the advice for installing the module, namely:

    install -d /lib/modules/2.14.18-3/kernel/drivers/scsi
    install -c hpt371.o /lib/modules/2.14.18-3/kernel/drivers/scsi

    As I have no other SCSI adapters, I amended /etc/modules.conf and added

    probeall block-major-8 hpt371
    options -k hpt371

    as per the instructions and rebooted. However, that didn't load the module, and I still had to used insmod to load it. What stage have I missed out?

    Thanks in advance.

  2. #2
    Just Joined!
    Join Date
    Sep 2006
    Posts
    2
    Solved it.

    Realising that I needed to have drives and partitions on this IDE connector availabe during boot, I came to the conclusion that I needed to add this to the booting image.

    I had problems doing that, but only because I forgot to copy sd_mod.o and scsi_mod.o to the RAM disk image (I'd already copied hpt371.o). Added insmod /lib/<module>.o to linuxrc and rebooted. All now well.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •