Find the answer to your Linux question:
Results 1 to 4 of 4
I am having trouble getting the sound working on my audigy 2 zs in Mandrake 10. Every time i boot up mandrake i get this message: Sound server informational message: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Posts
    11

    No sound in Mandrake 10 Community


    I am having trouble getting the sound working on my audigy 2 zs in Mandrake 10. Every time i boot up mandrake i get this message:

    Sound server informational message:
    Error while initializing the sound driver:
    device: default can't be opened for playback (No such file or directory)
    The sound server will continue, using the null output device.

    This also comes up when i go to System/Configuration/KDE/Sound/Sound System in the start menu and try to enable the Sound System. When i open kmix it is basically blank (no sliders or anything). There is only an empty drop down menu that is labeled Current Mixer. When i click on my sound card in Mandrake Control Center this is what comes up:

    Vendor: Creative Labs
    Alternative drivers: snd-emu10k1
    Bus: PCI
    Bus identification: 1102:4:1102:2002
    Location on the bus: 1:8:0
    Description: EMU10K2 Audigy Audio Processor
    Module: audigy
    Media class: MULTIMEDIA_AUDIO

    If i click on run config tool the displayed options for driver are snd-emu10k1, emu10k1, and audigy, currently at snd-emu10k1. However, changing the driver doesn't seem to help.

    A couple other things i noticed that are probably unimportant. I read of a similar problem on another message board and it was suggested that I my add username into the audio group, but in the Mandrake Linux User Management Tool the only group i see is my username. Also there is no dsp folder in /dev/ (read somewhere that this was related to sound).

    I'm kind of a Linux newb. Can Anyone help?

  2. #2
    Just Joined!
    Join Date
    Mar 2004
    Location
    Piscataway, NJ
    Posts
    27
    Do you have a .esd_auth in your home directory? Make sure you own that file, not root.

  3. #3
    Just Joined!
    Join Date
    Mar 2004
    Posts
    11
    Yes i have it and yes i am the owner

  4. #4
    Just Joined!
    Join Date
    Mar 2004
    Location
    Georgia
    Posts
    3

    Mandrake 10 - AUDIGY LIVES - Here's how I did it.

    With a few hints on this site... and the MandrakeUsers Forum - AUDIGY LIVES!

    * If you have upgraded as I did from 9.2, make sure you uninstall XMMS
    * Install alsa-utils (easy way is urpmi alsa-utils from a shell)
    * Run and check if the mixer levels are set to zero... if so, change.
    * Reinstall XMMS (urpmi xmms and then xmms- for extras if needed)
    * Open xmms
    * Change Preferences to ALSA mixer.

    .... at this point I choose a song / CD and get it playing....
    if it crashes something is wrong with XMMS setup.

    * Open Kmix (Alt+F2 and type kmix)
    * Right-click on the speaker icon in the tray
    * Choose Configure kmix.
    * Check the Advanced tab
    * UNCHECK / turn off the Audigy Analog option below the Sound Blaster Audigy slider.

    Did it work? Mine is fine now and sounds much better than 9.2 - thanks to the Audigy modules.

    nomasteryoda out -- time for some Tunes!
    MGALUG Website

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •