Find the answer to your Linux question:
Results 1 to 4 of 4
Hi guys, I've found the following repeated over and over again in dmesg, Code: ALSA sound/core/control.c:635: BUG? (info->access == 0) Call Trace: <ffffffff881e000f>{:snd:snd_ctl_elem_info+147} <ffffffff881e0d04>{:snd:snd_ctl_ioctl+630} <ffffffff8018b6c9>{do_ioctl+33} <ffffffff8018b95b>{vfs_ioctl+584} <ffffffff8018b9d6>{sys_ioctl+98} <ffffffff8010a7b6>{system_call+126} Does anyone ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414

    Sound card error messages in dmesg


    Hi guys,
    I've found the following repeated over and over again in dmesg,
    Code:
    ALSA sound/core/control.c:635: BUG? (info->access == 0)
    
    Call Trace: <ffffffff881e000f>{:snd:snd_ctl_elem_info+147}
           <ffffffff881e0d04>{:snd:snd_ctl_ioctl+630} <ffffffff8018b6c9>{do_ioctl+33}
           <ffffffff8018b95b>{vfs_ioctl+584} <ffffffff8018b9d6>{sys_ioctl+98}
           <ffffffff8010a7b6>{system_call+126}
    Does anyone know what it means? My sound card appears to work fine, since I can play CDs, and chat on Skype, but I'd really like to know what this error means, and what I can do about it.

    I've searched on the term "sound/core/control.c:635: BUG?", but there are only a couple of not-very-useful hits.

    Can anyone help me with this?
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  2. #2
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    Any idea what this means? What should I be searching for?
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  3. #3
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    I hate the feeling that there's something 'wrong' with my computer -- even if it appears to be running smoothly -- and the continual recurrence of this message is starting to get to me!

    Can anyone help me?
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

  4. #4
    Linux Guru smolloy's Avatar
    Join Date
    Apr 2005
    Location
    CA, but from N.Ireland
    Posts
    2,414
    I guess no one knows the answer to this.

    My audio hasn't been running as smoothly as it should. ~50% of the time skype refuses to work, and sometimes there's no sound from online videos. A reboot normally fixes things, but this isn't an acceptable solution. When this message appears in the logs it repeats dozens of times inside a few seconds.

    Does anyone have any ideas?
    Registered Linux user #388328 || Registered LFS user #15880
    AMD 64 X2 4600+ :: 2X1GB DDR2 800 :: GeForce 9400 GT 512MB :: ASUS M2N32 Deluxe :: 4X250GB SATAII
    Need instant help? Try us on IRC -- #linuxforums on freenode

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •