Find the answer to your Linux question:
Results 1 to 2 of 2
In hopes of helping other who might have the same type of config as me ... For some time now I've not been able to get my Logitech wheel mouse ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2003
    Posts
    41

    HowTo - Enable Logitech mouse wheel in Slackware 9.1


    In hopes of helping other who might have the same type of config as me ...

    For some time now I've not been able to get my Logitech wheel mouse (PS/2) wheel to work on Slackware 9.1.
    I wasn't able to directly find information pertaining to my mouse and OS, so I did a little playing (logic use of other configs).

    Here's what I did:

    In the /etc/X11/XF86Config file (in the mouse (Core Pointer's Input Device section)):

    Uncommented the following line
    Option "Protocol" "Auto"
    Added the following line
    Option "ZAxisMapping" "4 5"

  2. #2
    Linux User
    Join Date
    Jan 2003
    Location
    Cardiff, Wales
    Posts
    478

    more info

    Just to elaborate for those with this trouble.

    the settings need to go in your X config file often called something like /etc/X11/XF86Config

    you locate the section for you mouse and make sure it has the Zaxis setting. A snippet from my config is shown below.

    Code:
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "IMPS/2"
    	Option	    "Device" "/dev/psaux"
    	Option	    "ZAxisMapping" "4 5"
    	Option	    "Emulate3Buttons" "no"
    EndSection
    Always nice to see posts that give help!
    No trees were harmed during the creation of this message. Its made from a blend of elephant tusk and dolphin meat.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •