Find the answer to your Linux question:
Results 1 to 3 of 3
Hi there, Has anyone managed to get Sound Blaster Audigy 2 ZS for notebooks (pcmcia) working on debian? On kubuntu it worked fine. But Debian halts once I insert the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2006
    Posts
    2

    Sound Blaster Audigy 2 ZS Notebook + Debian = Halt?


    Hi there,

    Has anyone managed to get Sound Blaster Audigy 2 ZS for notebooks (pcmcia)
    working on debian? On kubuntu it worked fine. But Debian halts once I
    insert the card or when it is detected in the start up.

    I have: Debian GNU/Linux 3.1 (sarge), with kernel: Linux 2.4.27-3-686.

    All ideas appriciated! Thx!

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    I have a feeling it is the fact you are using the 2.4 kernel. kubuntu uses 2.6
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    Just Joined!
    Join Date
    Dec 2006
    Posts
    2
    Thx! The Linux kernel version 2.6.8-3-686 stopped the halt on card
    detection. But I am still unable to get sound out of the device.

    I have two sound cards of which the other is an internal SiS chip using the intel8x0 module which works fine.

    lspci -v says:

    0000:00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS]
    Sound Controller (rev a0)
    Subsystem: Wistron Corp.: Unknown device 2000
    Flags: bus master, medium devsel, latency 173, IRQ 11
    I/O ports at 1c00 [size=256]
    I/O ports at 1800 [size=128]
    Capabilities: [48] Power Management version 2

    0000:02:00.0 Multimedia audio controller: Creative Labs: Unknown device 0008
    Subsystem: Creative Labs: Unknown device 2001
    Flags: medium devsel, IRQ 11
    I/O ports at 4000 [disabled] [size=64]
    Capabilities: [dc] Power Management version 2

    cardctl says:

    Socket 0:
    product info: "CREATIVE", "CARDBUS AUDIO"
    manfid: 0x012b, 0x0101
    function: 254 ((null))

    /etc/modules.conf seems abit messy after all the configuration.. you can
    have a look at it here: http://www.wizmelee.net/modules_conf_emu10k1.txt

    What i have pretty much done is:

    Selected the two drivers (intel8x0 & emuk10k1) with: dpkg-reconfigure
    alsa-source.

    Built & installed the alsa module with module-assistant.

    When i run alsaconf, select emuk10k1 (intel8x0 works fine). It does the
    configuration ok, but the last step (preparing the card for playing, loading
    alsa driver) halts. Also just doing modprobe snd-emu10k1 makes the system
    freeze.

    I noticed that they are already listed in lsmod but no sound comes out of
    /dev/dsp1,2or3. /dev/dsp or dsp0 works fine for the SiS soundcard.

    heres my lsmod: http://www.wizmelee.net/lsmod_emu10k1.txt

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •