Hello all,

I am having issues with my webcam. I'm not sure if the device is truly 'supported' under FC5 but it is recognized by the kernel and loads as /dev/video0

Hi all, I'm having some issues with my webcam. It is recognized by the kernel as shown by the output from dmesg

[sean@localhost ~]$ dmesg |less
Linux video capture interface: v2.00
sn9c102: V4L2 driver for SN9C10x PC Camera Controllers v1:1.27
usb 2-3: SN9C10[12] PC Camera Controller detected (vid/pid 0x0C45/0x6029)
usb 2-3: PAS106B image sensor detected
usb 2-3: Initialization succeeded
usb 2-3: V4L2 device registered as /dev/video0
usbcore: registered new driver sn9c102

It is also recognized when I run lsusb

[sean@localhost ~]$ /sbin/lsusb
Bus 005 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 004 Device 002: ID 03f0:3304 Hewlett-Packard DeskJet 990c
Bus 004 Device 001: ID 0000:0000
Bus 002 Device 002: ID 0c45:6029 Microdia Triplex i-mini PC Camera
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

When I attempt to use an application like camE, I receive the following results.

[root@localhost ~]# camE
camE: camE 1.9 - (c) 1999, 2000 Gerd Knorr, Tom Gilbert
camE: grabber config: size 320x240, input 0, norm 0, jpeg quality 75
You have new mail in /var/spool/mail/root
[root@localhost ~]# can't load font arial/8
can't load font arial/8
/dev/video0: no v4l device

When I attempt to use CamStream, select Open viewer the window that appears does not have any devices listed.

I'm wondering where I should go from here. I guess my first thought is that the webcam is not supported yet.

Any help would be appreciated.