Find the answer to your Linux question:
Results 1 to 5 of 5
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    3Com 905B-TX won't configure


    I've been trying to get this Mandrake box on my network for hours now (running 9.2 with the 2.6.2 kernel). Here's where I stand:

    * 3c59x is loaded, verified with lsmod
    * Corrosponding LED on the hub blinks once every 3 seconds
    * Cable has been tested with another system and works

    When I run drakconfig, it prompts me for a module to load. I give it the 3c59x module and click next. The module loads ok. It then takes me back to the "What do you want to configure screen," so I select LAN connection, and it prompts me for a module to load again. It will run in circles like that forever.

    Can anyone help me?

  2. #2
    After hours and hours of messing with it, I'm just going to throw the damn thing out, and go drop $20 on a NIC that I know should work.

  3. #3
    Well, did you do a google search? Remember google is your friend.
    Do a seArch for "3c905 and mandrake". You'll see that there is a problem and fix's that other people have done to get it working.

  4. $spacer_open
    $spacer_close
  5. #4
    Yes, I've googled for it many times. I hesitated to buy a new card, esp since Ratshack wants $25 for a 10/100 ethernet card. I pulled the one out of my XP system, one that I had working with Mandrake before. It's doing the same repeating thing, and modprobe is erroring with 256. I suspect the problem is much deeper than I thought. I'm taking it to the networking board, since I know it's not hardware anymore.

  6. #5
    -->
    Alright, I'll admit that all I did was google and didn't read any of the post that were returned, but there looked like there were plenty. After your last post I did check them out and they don't look very helpful.

    I got this info a while back after upgrading to fedora core 1 and had the same problem you are describing with the 3c905. The OS said it was OK, it loaded fine, and all the lights (linksys and on the card it's self) were good and the cable had just worked an hour befor the upgrade so it wans't that. And I could boot into WinXP and the card worked in the machine fine. The funny thing is that it was an upgrade from RedHat 9. So it broke in between ver9 and fedora.

    After searching through google I found a link to a bugzilla bug. It's about fedora, but it's where I got the link's below to the drivers and it might be worth your time looking at it. Scroll through it to the "additional comments". It looks like in fedora that it isn't using the latest drivers and for ferora at least there are some other problems. I ended up turning off the kudzu service (a new hardwware probe) under fedora and it works like a champ.

    https://bugzilla.redhat.com/bugzilla....cgi?id=102685

    So here is where to get the 3c905 and linux drivers
    http://www.scyld.com/network/vortex.html
    or
    ftp://ftp.scyld.com/pub/network/3c59x.c

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •