Find the answer to your Linux question:
Results 1 to 7 of 7
Ok I'm missing something but cannot figure out what. I recently got a an Epson Perfection V100 after checking and finding it had good Linux support. I first tried it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    73

    Epson Perfection v100 can see but cannot scan


    Ok I'm missing something but cannot figure out what.

    I recently got a an Epson Perfection V100 after checking and finding it had good Linux support. I first tried it on an FC5 box. I installed the latest Sane backends. Then I tried it on an FC6 box with same lack of success.

    T: Bus=03 Lev=01 Prnt=01 Port=03 Cnt=01 Dev#= 2 Spd=480 MxCh= 0
    D: Ver= 2.00 Cls=ff(vend.) Sub=ff Prot=ff MxPS=64 #Cfgs= 1
    P: Vendor=04b8 ProdID=012d Rev= 1.00
    S: Manufacturer=EPSON
    S: Product=EPSON Scanner
    C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr= 2mA
    I: If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
    E: Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
    E: Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=31875us

    The USB bus sees it.

    [root@gandalf hold]# sane-find-scanner

    # sane-find-scanner will now attempt to detect your scanner. If the
    # result is different from what you expected, first make sure your
    # scanner is powered up and properly connected to your computer.

    # No SCSI scanners found. If you expected something different, make sure that
    # you have loaded a kernel SCSI driver for your SCSI adapter.
    # Also you need support for SCSI Generic (sg) in your operating system.
    # If using Linux, try "modprobe sg".

    found USB scanner (vendor=0x04b8 [EPSON], product=0x012d [EPSON Scanner]) at libusb:003:002
    # Your USB scanner was (probably) detected. It may or may not be supported by
    # SANE. Try scanimage -L and read the backend's manpage.

    # Not checking for parallel port scanners.

    Sane can see it, tell me it's there.

    I installed Iscan, and any attempt to scan comes up with cannot send command to scanner both as root or as normal user.

    I edited /ect/sand.d/ epson.conf and ekowa.conf to remark out SCSI scanning.
    I tried adding this line to the epson.conf file with no success
    usb /dev/scanner-usbdev3.2

    which is what it shows up as in /dev

    Xsane just tells me it no devices availible both as root or normal user. This is both as the Gimp plugin or running Xsane directly from the command line.

    I tried to force it on the FC5 box using the usb <product ID> <device ID> but could never figure out how to get the device ID. I tried using what USB bus it was on but that gave me same result as all other efforts.

    I know I'm overlooking something but cannot figure out what I'm over looking.

  2. #2
    Just Joined!
    Join Date
    May 2006
    Posts
    73
    After 2 days of misery I found the problem. Turns out the problem was with SELinux and I found that only when dealing with a seperate printing issue.

    running
    chcon -t textrel_shlib_t /usr/lib/sane/libsane-epkowa.so.1.0.15
    as suggest fixed the problem.


    SummarySELinux is preventing /usr/bin/xsane from loading /usr/lib/sane/libsane-epkowa.so.1.0.15 which requires text relocation.Detailed DescriptionThe /usr/bin/xsane application attempted to load /usr/lib/sane/libsane-epkowa.so.1.0.15 which requires text relocation. This is a potential security problem. Most libraries do not need this permission. Libraries are sometimes coded incorrectly and request this permission. The SELinux Memory Protection Tests web page explains how to remove this requirement. You can configure SELinux temporarily to allow /usr/lib/sane/libsane-epkowa.so.1.0.15 to use relocation as a workaround, until the library is fixed. Please file a bug report against this package.

    If you trust /usr/lib/sane/libsane-epkowa.so.1.0.15 to run correctly, you can change the file context to textrel_shlib_t. "chcon -t textrel_shlib_t /usr/lib/sane/libsane-epkowa.so.1.0.15"The following command will allow this access:chcon -t textrel_shlib_t /usr/lib/sane/libsane-epkowa.so.1.0.15

    _
    Source Context: user_u:system_r:unconfined_tTarget Context: system_u:object_r:lib_tTarget Objects: /usr/lib/sane/libsane-epkowa.so.1.0.15 [ file ]Affected RPM Packages: xsane-0.991-4.fc6 [application]iscan-2.3.0-1.c2 [target]Policy RPM: selinux-policy-2.4.6-13.fc6Selinux Enabled: TruePolicy Type: targetedMLS Enabled: TrueEnforcing Mode: EnforcingPlugin Name: plugins.allow_execmodHost Name: gandalfPlatform: Linux gandalf 2.6.18-1.2868.fc6xen #1 SMP Fri Dec 15 18:20:31 EST 2006 i686 athlonAlert Count: 11Line Numbers: Raw Audit Messages :avc: denied { execmod } for comm="xsane" dev=hdc6 egid=501 euid=501 exe="/usr/bin/xsane" exit=-13 fsgid=501 fsuid=501 gid=501 items=0 name="libsane-epkowa.so.1.0.15" path="/usr/lib/sane/libsane-epkowa.so.1.0.15" pid=16691 scontext=user_u:system_r:unconfined_t:s0 sgid=501 subj=user_u:system_r:unconfined_t:s0 suid=501 tclass=file tcontext=system_u:object_r:lib_t:s0 tty=pts13 uid=501

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    11

    Scanning

    I am using PCLinuxOS and am having trouble trying to scan from an Epson DX4850 hung from my windows box. Printing is fine, set up using KDE. Have you had any experience of accessing a remote scanner across a network? I have tested the scanner out using the Live CD on the windows box and it works great. I have done some research but most info relates to the opposite installation where the scanner is hung fron a Linux box and allows windows boxes to access it. Any suggestions would be appreciated.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    May 2006
    Posts
    73
    I've set up printers hung off windoze boxes before but never a scanner. Didn't know it was possible to have a network scanner in windoze actually. Only networked scanners I am aware of are all hung off Nix boxes. I would try SMB4 and see if you can browse the scanner. It's an outgoing port so it shouldn't be a problem with your firewall on the Linux side. What firewall are you using on the Windoze box? It might be blocking external connections to the scanner. It's a little out of my waters. Wish I could be of more help.

  6. #5
    Just Joined!
    Join Date
    Jan 2007
    Posts
    11
    I am using Zonealarm with Antivirus on the Windows Box. I have had problems accessing the windows box from Linux as initially I was able to see it through samba shares ( having just tried I can see it at the moment ) but most of the time I have to use smb4K to see it. How would I be able to differentiate between the printer and scanner as it is an all-in-one? I can drill down to the Epson files on the windows harddrive. In windows I can see the scanner under scanners and cameras but there appears to be no way of sharing it as there is printers. I have read about using Sane network backend to allow windows boxes to access Linux scanners and using Sanetwain on the windows box. I'm fairly new to Linux and this is the only problem that I have not been able to solve yet.

  7. #6
    Just Joined!
    Join Date
    May 2006
    Posts
    73
    The sane backend seems to make it easy to network a scanner for Nix. You can try compiling them under Windows. Barring that you'll need something like
    http://www.remote-scan.com/
    as it appears that windows has no native ability to share scanners.
    A second thing you'll need to do is install the drivers for the Epson on the Linux boxes. The Epson Perfection scanners do not have open source drivers. They are free from
    http://www.avasys.jp/english/linux_e/dl_scan.html
    but from what I have read sane won't include them because they are not GPL. I am not sure how accurate why they are not supported by Sane but in the supported list by Sane is a link to the Avasys web site.

    After installing that you can use Iscan from Avasys or Xsane. You have to enable network scanning in the epson and Epkowa config files in /etc/sane.d/ If I remember correctly that's just set by default, if not you merely need to unremark one line and possibly remark out any local reference to scanners such as USB and SCSI. Even with a local scanner it's advisable or necessary to remark out the default SCSI in the config files.

    With Zonealarm you'll need to find out which port, at worst you can slap a sniffer on your Linux box and watch for outgoing traffic to the box you have the scanner on and open those ports. There might be documentation on which ports need to be open in the sane documentation. I like Zonealarm myself. Don't have any windoze machines to put it on, but would love to have a Zonealarm type interface over IPTables.

  8. #7
    Just Joined!
    Join Date
    Jan 2007
    Posts
    11
    Thanks for your help. It looks to me as though it will be easier to hang the scanner off the linux box and then network it from windows. As soon as I have time I think I'll try.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •