Find the answer to your Linux question:
Results 1 to 3 of 3
Hello: For a remote control system (Avocent DSR-based system) I need to turn off the mouse acceleration on all servers. Generally this has been easy but Linux has proven to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Posts
    2

    Setting the xset "System Default" mouse accelerati


    Hello:

    For a remote control system (Avocent DSR-based system) I need to turn off the mouse acceleration on all servers. Generally this has been easy but Linux has proven to be harder than I thought.

    I modify the /etc/X11/xinit/xinitrc to include the "xset m 0" as the last item prior to spawning the window manager. Generally this works, but for some versions of GNOME it appears that the system default acceleration is reset when the window manager starts.

    For me the best solution appears to set the XFree86 mouse acceleration default from 2 to 0. More specifically, how do I modify the system so that the command "xset m default" will set the acceleration to 0 and not 2?

    Any ideas?

    Thanks,

    Sean Dickman

  2. #2
    Just Joined!
    Join Date
    Apr 2004
    Posts
    2
    Finally found a partial solution.

    The default acceleration is controlled by the value of "defaultPointerControl.num" which is referenced in the devices.c file. Unfortunately I couldn't find where this variable is initialized. But, the util.c will set this variable if X is started with the "-a #" option.

    So, the easy way to set the default is to modify the startup script to include this parameter. In RedHat for instance, modify the startx program to include the following line:

    defaultserverargs="-a 0"

    This doesn't work if the installation uses xdm to provide a graphical logon. Somehow I still need to setup Xserver so that by default for all instance that the server is started it uses the "-a 0" parameters.

    Sean Dickman

  3. #3
    Just Joined!
    Join Date
    Mar 2006
    Posts
    1
    Another way in RHEL3u4

    edit motion_acceleration value in /root/.gconf/desktop/gnome/peripherals/mouse/%gconf.xml

    I used a value of 1 for no acceleration.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •