My laptop died and I'm sending it back for a new one, unfortunately I was not able to backup my important stuff before its death (out of stupidity, I tested both memory and the hard drive, both had no problems so I kept using it even after its random freezes until I could no longer boot; kept putting off my needed small backup).

I have a sata-to-usb connecty-thing from bytecc and dmesg says:
Code:
scsi1 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 4
usb-storage: waiting for device to settle before scanning
  Vendor:           Model:                   Rev:
  Type:   Direct-Access                      ANSI SCSI revision: 02
sd 1:0:0:0: Attached scsi disk sda
sd 1:0:0:0: Attached scsi generic sg0 type 0
usb-storage: device scan complete
It had a gentoo installation with 5 partitions (/ /usr /var /tmp and swap), all reiser (except swap of course). However I don't know how to access the drive as only /dev/sda comes up.

How do I go about accessing this thing?
Thanks.

Edit: Just tried "fdisk /dev/sda"--said "Unable to read /dev/sda".
"fdisk -l /dev/sda" has no output.

Solved: It was a user error, embarrassingly enough I hadn't plugged in both ends of the power cord.