Hello all,

I recently tried to install a Logitech Communicate STX USB webcam on my desktop running Suse 10.2. I tried to follow the directions in another thread:

You will need the to download the source code for the web cam driver here:
http://mxhaard.free.fr/spca50x/Down...20060925.tar.gz

Unpack the tar file and then go into the directory it upacks to. Run Make and as root run make install. Now unfortunately even though it runs the install correctly it doesn't get anywhere that 'insmod' seems to see it. So you need to copy the .ko file to a directory it belongs in.

as root: cp gspca.ko /lib/modules/2.6.17-1.2187_FC5smp/kernel/drivers/input/misc/

Now the kicker 'insmod' still won't see it SO i did a neat little cheat. Go to the directory you copied it in using a GUI file browser as super user. I don't know if this works in Gnome but in KDE you can right click it and select "Open With" and in the dialog box type insmod then select 'OK'.


But when I go to the directory and type make, I get the following output:
make -C /lib/modules/`uname -r`/build SUBDIRS=/home/drew/Desktop/gspcav1-20070110/gspcav1-20070110 CC=cc modules
make[1]: Entering directory `/usr/src/linux-2.6.18.2-34-obj/i386/default'
make[1]: *** No rule to make target `modules'. Stop.
make[1]: Leaving directory `/usr/src/linux-2.6.18.2-34-obj/i386/default'
make: *** [default] Error 2


And when I type make install, I get:
mkdir -p /lib/modules/`uname -r`/kernel/drivers/usb/media/
rm -f /lib/modules/`uname -r`/kernel/drivers/usb/media/spca5xx.ko
rm -f /lib/modules/`uname -r`/kernel/drivers/media/video/gspca.ko
install -c -m 0644 gspca.ko /lib/modules/`uname -r`/kernel/drivers/usb/media/
install: cannot stat `gspca.ko': No such file or directory
make: *** [install] Error 1


Naturally I can't get any farther than that and can't find the gspca.ko file, to which it seems to refer, anywhere.