Find the answer to your Linux question:
Results 1 to 2 of 2
I've got a 40 GB drive that was in a notebook that crapped out. I've put it in an external USB enclosure and have tried connecting it to a Windows ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1

    USB drive detected in /proc/usb, but not listed as /dev/sda: what to do?


    I've got a 40 GB drive that was in a notebook that crapped out. I've put it in an external USB enclosure and have tried connecting it to a Windows notebook. WinXP Disk Management doesn't recognize or see the drive.

    Next I've tried the same notebook booting up in Knoppix 5.01. Knoppix sees the device, that is, it's listed in /proc/bus/usb/001/005, but there is no entry for the drive in /dev. So, no /dev/sda1, no /dev/sdb1, nada.

    I've looked in many places but don't see how to get a /dev entry so I try mounting it. Any suggestions to share?

    thanks
    S

  2. #2
    Linux Engineer Zelmo's Avatar
    Join Date
    Jan 2006
    Location
    Riverton, UT, USA
    Posts
    1,001
    How 'bout dmesg? When you plug in the drive and run dmesg, I'm assuming you'll see some lines at the end relating to the drive (since /proc/usb has entries for it). There may be enough there to work with that you can get udev to create a device node for it. See this page for details on how to write udev rules. In particular, check out the hard disk example.
    Stand up and be counted as a Linux user!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •