Find the answer to your Linux question:
Results 1 to 5 of 5
my monitor refuses to work in the GUI, it halts everytime i run the Xwindows, i've tried everyway that could be possible, XF86Config are not working when i run it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Location
    Amman/Jordan
    Posts
    5

    monitor problem


    my monitor refuses to work in the GUI, it halts everytime i run the Xwindows, i've tried everyway that could be possible, XF86Config are not working when i run it the monitor also halts. Alse tried Redhat-Config-XFree86 and the same problem occured...
    what can i do now?
    thank u

  2. #2
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    Is everything configured correct? Do you know the vert. and hori. sync rate for your monitor? If so, enter "xf86config" as root and configure you monitor correctly. Maybe the Redhat program screwed up somehow?

    Good luck

  3. #3
    Linux Newbie
    Join Date
    Apr 2004
    Location
    Stockholm, Sweden
    Posts
    130

    hm?

    if you posted your XF86Config it might be easier to solve the problem...

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2004
    Location
    Amman/Jordan
    Posts
    5

    XF86Config

    # XFree86 4 configuration created by pyxf86config

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen 0 "Screen0" 0 0
    InputDevice "Mouse0" "CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "DevInputMice" "AlwaysCore"
    EndSection

    Section "Files"

    # RgbPath is the location of the RGB database. Note, this is the name of the
    # file minus the extension (like ".txt" or ".db"). There is normally
    # no need to change the default.
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Red Hat 6.0 and later now use a font server independent of
    # the X server to render fonts.
    RgbPath "/usr/X11R6/lib/X11/rgb"
    FontPath "unix/:7100"
    EndSection

    Section "Module"
    Load "dbe"
    Load "extmod"
    Load "fbdevhw"
    Load "glx"
    Load "record"
    Load "freetype"
    Load "type1"
    Load "dri"
    EndSection

    Section "InputDevice"

    # Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
    # Option "Xleds" "1 2 3"
    # To disable the XKEYBOARD extension, uncomment XkbDisable.
    # Option "XkbDisable"
    # To customise the XKB settings to suit your keyboard, modify the
    # lines below (which are the defaults). For example, for a non-U.S.
    # keyboard, you will probably want to use:
    # Option "XkbModel" "pc102"
    # If you have a US Microsoft Natural keyboard, you can use:
    # Option "XkbModel" "microsoft"
    #
    # Then to change the language, change the Layout setting.
    # For example, a german layout can be obtained with:
    # Option "XkbLayout" "de"
    # or:
    # Option "XkbLayout" "de"
    # Option "XkbVariant" "nodeadkeys"
    #
    # If you'd like to switch the positions of your capslock and
    # control keys, use:
    # Option "XkbOptions" "ctrl:swapcaps"
    # Or if you just want both to be control, use:
    # Option "XkbOptions" "ctrl:nocaps"
    #
    Identifier "Keyboard0"
    Driver "keyboard"
    Option "XkbRules" "xfree86"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "yes"
    EndSection

    Section "InputDevice"

    # If the normal CorePointer mouse is not a USB mouse then
    # this input device can be used in AlwaysCore mode to let you
    # also use USB mice at the same time.
    Identifier "DevInputMice"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/input/mice"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "no"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Monitor Vendor"
    ModelName "Unprobed Monitor"
    HorizSync 30.0 - 50.0
    VertRefresh 50.0 - 100.0
    Option "dpms"
    EndSection

    Section "Device"
    Identifier "Videocard0"
    Driver "nv"
    VendorName "Videocard vendor"
    BoardName "NVIDIA GeForce 2 MX (generic)"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Videocard0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    Modes "640x480"
    EndSubSection
    EndSection

    Section "DRI"
    Group 0
    Mode 0666
    EndSection

  6. #5
    Linux Newbie
    Join Date
    Apr 2004
    Location
    Stockholm, Sweden
    Posts
    130
    A few tips:
    SubSection "Display"
    Depth 24
    Modes "640x480"
    EndSubSection

    Try changing depth to 8, just to test if it works then....maybe your videocard doesn't support 640x480x24 (although I find that unlikely). The second thing I would do is check the videocard AND monitor manual (in case you have a weird monitor or something) to find a resolution they both support, and input it here. Other things you can try is to change your
    HorizSync 30.0 - 50.0
    VertRefresh 50.0 - 100.0
    to something else. (check monitor manual).

    If nothing of this works, I'd try to comment out the "DRI Section" and see if that it messing things up.

    When the screen locks up, try pressing Ctrl-Alt-F1 multiple times, and see if you can get back to console mode. If you can, please post whatever output the X server has sent so I can look at that also.

    Good Luck

    /ooop

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •