Find the answer to your Linux question:
Results 1 to 7 of 7
Hi all, Apologies for missing out on any conventions in this post but I'm pretty new to Linux. I have a Nebula Electronics PCI DVB-T card running on an Asus ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    5

    Question DVB pci card - DVB_bt8xx fails after 10 minutes


    Hi all,

    Apologies for missing out on any conventions in this post but I'm pretty new to Linux.

    I have a Nebula Electronics PCI DVB-T card running on an Asus AM2 mobo, has been working just fine for a couple of months on Fedora Core 6 but after foolishly letting an automatic update do a kernel update to kernel-2.6.18-1.2798.fc6.x86_64 it only works for about 10 minutes, at least I think that was when the problem started. If I modprobe -r dvb_bt8xx followed by modprobe dvb_bt8xx I buy myself another 10 minutes.

    I do normally use MythTV but installed Kaffeine to make testing a bit easier, and that displays the video just fine albeit with the sound gradually going out of sync until after about 10 minutes has elapsed when the picture and sound just freezes. I have since updated to 2.6.19-1 but with no change. when checking the dmesg output after the picture freeze it complains that it cannot write to various registers on the DVB card. The PC has a small partition with Windows XP (for testing) and that has no problems with the card at all, ruling out a hardware problem.

    I really do not know where to go next, and feel really frustrated by my lack of Linux knowledge but one small victory for Linux is that I keep typing in 'ls' instead of 'dir' at work now!

    Any help would be much appreciated, if it's useful I can post the lspci and dmesg output when I get home tonight.

  2. #2
    Just Joined!
    Join Date
    Jan 2007
    Posts
    5
    Obviously a bit too technical a question... Oh well, back to Windows...

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    5
    And I have just spent the last 3 days just getting Musicbrainz to work in Amorok, still have no sound in Helix as I can't get OSS emulation to work, still trying to fathom out how to get the iMon VFD on my Antec Fusion case to work, few hours of Googling comes up with I need LCDproc but it's not in the rpm's for Fedora so will need compiling...

    Somebody please remind me why the hell I am bothering with Linux?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast likwid's Avatar
    Join Date
    Dec 2006
    Location
    MA
    Posts
    649
    Because you will be uber-cool when you get it to work. Why don't you just roll back to the kernel version that worked?

  6. #5
    Just Joined!
    Join Date
    Jan 2007
    Posts
    5
    I typed a long witty and articulate reply to your reply, which I firstly must thank you for, including why I agree that Linux is cool except as sods law would have it the box crashed on me and I lost it all, hmm, not so much bad luck more like doing modprobe -r dvb_bt8xx was not a smart move...

    Tried a rollback, forward and a cartwheel, still the same, so anyway, breifly this time as I can't type that lot in again, a bit of relevant output from dmesg on a fresh <sigh> reboot that maybe might cause a passing soul to have a lightbulb moment:

    Linux video capture interface: v2.00
    bttv: driver version 0.9.16 loaded
    bttv: using 8 buffers with 2080k (520 pages) each for capture
    eth0: forcedeth.c: subsystem: 01043:816a bound to 0000:00:14.0
    i2c_adapter i2c-0: nForce2 SMBus adapter at 0x4c00
    i2c_adapter i2c-1: nForce2 SMBus adapter at 0x4c40
    EDAC MC0: Giving out device to k8_edac Athlon64/Opteron: DEV 0000:00:18.2
    shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
    bttv: Bt8xx card found (0).
    ACPI: PCI Interrupt Link [APC2] enabled at IRQ 17
    ACPI: PCI Interrupt 0000:04:09.0[A] -> Link [APC2] -> GSI 17 (level, low) -> IRQ 17
    bttv0: Bt878 (rev 17) at 0000:04:09.0, irq: 17, latency: 32, mmio: 0xfdaff000
    bttv0: detected: Nebula Electronics DigiTV [card=104], PCI subsystem ID is 0071:0101
    bttv0: using: Nebula Electronics DigiTV [card=104,insmod option]
    bttv0: gpio: en=00000000, out=00000000 in=00ffffcb [init]
    bttv0: using tuner=-1
    bttv0: registered device video0
    bttv0: registered device vbi0
    bttv0: PLL: 28636363 => 35468950 .. ok
    bttv0: add subdevice "dvb0"
    input: bttv IR (card=104) as /class/input/input2
    bttv-input: bttv IR (card=104) detected at pci-0000:04:09.0/ir0

    lsmod | grep dvb:

    dvb_bt8xx 27461 6
    dvb_core 101105 1 dvb_bt8xx
    bt878 21001 1 dvb_bt8xx
    dvb_pll 25157 1 dvb_bt8xx
    bttv 224309 2 dvb_bt8xx,bt878
    i2c_core 34369 10 i2c_ec,mt352,nxt6000,dvb_bt8xx,nvidia,dvb_pll,bttv ,i2c_algo_bit,tveeprom,i2c_nforce2

    lspci:

    04:09.0 Multimedia video controller: Brooktree Corporation Bt878 Video Capture (rev 11)
    04:09.1 Multimedia controller: Brooktree Corporation Bt878 Audio Capture (rev 11)

    All looking very good, go into Kaffeine, cool, DVB-T working, tune to BBC News 24 so that I can easily see how long it stays up for, just look at the on screen clock.

    Okay, spot on 5 minutes when I timed it, and as soon as the picture freezes I get this from dmesg, same line repeated about fifety times:

    mt352_read_register: readreg error (reg=0, ret==-5)

    If it did not work, great, something to look for, but work and then stop is not easy to track down and I have run out of ideas.

  7. #6
    Linux Enthusiast likwid's Avatar
    Join Date
    Dec 2006
    Location
    MA
    Posts
    649
    I am not familiar with using video for linux but, are these modules open source? If so it should be relatively easy to find out who wrote them or where there is a mailing list for users of this module. I would post to this mailing list or e-mail the programmer with this error and ask for an explanation.

  8. #7
    Just Joined!
    Join Date
    Jan 2007
    Posts
    5
    Thanks for the replies, and as a consequence I've mailed the V4L Fedoras list, fingers crossed!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •