Find the answer to your Linux question:
Results 1 to 2 of 2
Hello. I've bought a new disk to replace an old one that worked for years and now started to seem like dying. The old disk was a Hitachi Travelmaster 2,5" ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    2

    extremely slow reading from IDE disk


    Hello.

    I've bought a new disk to replace an old one that worked for years and now started to seem like dying. The old disk was a Hitachi Travelmaster 2,5" 30GB.. not sure which series. The new one is a Hitachi Travelmaster 5K100 2.5" 80GB.

    The first problem with the new disk was system detecting wrong geometry for the disk, which I managed to fix by passing the hda parameter to the kernel when booting. Not sure whether this does have somtehing to do with the current issue so I just wanted to mention it.

    Right now the disk is working pretty fine except for one thing... it won't read
    According to gkrellm the disk reads about 55MB of data at a normal rate and then drops to 0-230KB/s, with the yellow LED still on.

    hdparm -Tt /dev/hda shows nothing suspicious:
    Timing cached reads: 532 MB in 2.01 seconds = 265.22 MB/sec
    Timing buffered disk reads: 58 MB in 3.04 seconds = 19.10 MB/sec

    these are the rates I have expected.
    but... bonnie:
    HTML Code:
                  -------Sequential Output-------- ---Sequential Input-- --Random--
                  -Per Char- --Block--- -Rewrite-- -Per Char- --Block--- --Seeks---
    Machine    MB K/sec %CPU K/sec %CPU K/sec %CPU K/sec %CPU K/sec %CPU  /sec %CPU
              250  8216 95.3 22825 30.0   288  0.3   178  1.9   411  0.2  63.4  0.8
    .. and bonnie++:
    HTML Code:
    Version 1.93c       ------Sequential Output------ --Sequential Input- --Random-
    Concurrency   1     -Per Chr- --Block-- -Rewrite- -Per Chr- --Block-- --Seeks--
    Machine        Size K/sec %CP K/sec %CP K/sec %CP K/sec %CP K/sec %CP  /sec %CP
    habibi-halua   368M   133  98 18858  26   197   0   508  98   139   0  13.0   0
    Latency               108ms    3836ms   15790ms   43819us   21119ms    3892ms
    Version 1.93c       ------Sequential Create------ --------Random Create--------
    habibi-halua        -Create-- --Read--- -Delete-- -Create-- --Read--- -Delete--
                  files  /sec %CP  /sec %CP  /sec %CP  /sec %CP  /sec %CP  /sec %CP
                     16   410  97 +++++ +++ 20261  67   416  98 +++++ +++  1478  93
    Latency             82914us   11155us    2170us   80063us    1825us     163ms
    1.93c,1.93c,habibi-halua,1,1170088515,368M,,133,98,18858,26,197,0,508,98,139,0,13.0,0,16,,,,,410,97,+++++,+++,20261,67,416,98,+++++,+++,1478,93,108ms,3836ms,15790ms,43819us,21119ms,3892ms,82914us,11155us,2170us,80063us,1825us,163ms
    show that something is wrong.
    as far as I know, if the disk supports higher ATA standard than the IDE controller supports then it should set itself tu use the lower one. This seems to be done correctly as hdparm -I /dev/hda shows that the disk supports udma1-5 but is currently running with udma2.

    here is the output from hdparm /dev/hda:
    HTML Code:
    multcount    = 16 (on)
    IO_support   =  3 (32-bit w/sync)
    unmaskirq    =  0 (off)
    using_dma    =  1 (on)
    keepsettings =  0 (off)
    readonly     =  0 (off)
    readahead    = 256 (on)
    geometry     = 9729/255/63, sectors = 156301488, start = 0
    I think I've tried every reasonable combination of settings namely -A0/1 -W0/1 -c0/1/3 -m0/16 -u0/1 -d0/1 -X udma2/udma5
    but with no success.

    dmesg shows nothing suspicious but if you want I can paste it here.

    here I want to remind you that the older disk had worked well until recently, so I think other hw than the new disk should work as well.
    But then hdparm -Tt /dev/hda shows expected values so the disk should be okay too

    I've been scratching my head over this for a couple of days now and I think I've run out of options.. maybe I should just go to the seller and have it replaced with a new one.

    any help will be appreciated...

  2. #2
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2
    I'm not a expert but I have problems with my hard disk. Good luck I hope you will resolve your problem.
    Last edited by oz; 02-06-2007 at 05:27 AM. Reason: removed spam URL

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •