Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, so .. I already lost a my data, but for me its too much this time, I have an WD external drive, 200gb and i was putting it in ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2007
    Posts
    2

    Lost 100gb personal data, reiserfs


    Hi,

    so .. I already lost a my data, but for me its too much this time,
    I have an WD external drive, 200gb and i was putting it in order, transfering data to another disk and removing unused partitions, then there were 2 left (+ 1 extended).
    One of those had a reiserfs on it and I decided to resize it to the end of the drive, because I needed a temporary space. I did like described in man pages. I booted knoppix 5, deleted that partition using fdisk, then recreating the partition on the same cylinder and ending at the end of the drive, adding around 30-40gb to it. Then i ran resize_reiserfs like that:
    resize_reiserfs /dev/sdb5, without -s parameter, so that it resizes my partition to fit the new underlaying device.


    output of fdisk BEFORE doing anything:
    ------------------------------------------------------------------
    Disk /dev/sdb: 200.0 GB, 200049647616 bytes
    255 heads, 63 sectors/track, 24321 cylinders
    Units = cylinders of 16065 * 512 = 8225280

    Device Boot Start End Blocks Id System
    /dev/sdb2 * 1092 3062 15832057+ c W95 FAT32 (LBA)
    /dev/sdb4 3063 24321 170762917+ f W95 Ext'd (LBA)
    /dev/sdb5 5475 20064 117194143+ 83 Linux
    ----------------------------------------------------------------------
    These partitions were all created with fdisk, but I can not say for sure that they were never resised.





    then i deleted my reiserfs, sdb5 partition and created a new one. Output of the new one (fdisk was):

    /dev/sdb5 5475 24321 151388527+ 83 Linux


    then i ran this:
    --------------------------------
    # resize_reiserfs /dev/sdb5

    and got:
    resize_reiserfs 3.6.19 (2003 www.nemesys.com)


    reiserfs_open: the reiserfs superblock cannot be found on /dev/sdb5.
    ----------------------------------------

    At this point I realized something went wrong, perhaps something with the starting cylinder. In the man page it says that you have to create the partition on the same cylinder, and I did that, so WHAT can go wrong?

    At the moment I am thinking of cylinders. They are not so small, so could the filesystem start somewhere in the middle of a cylinder or anything?

    Do you know what happens when you create a new partition with fdisk? Where is the main part of the disk, where informations of the partitions are stored? is this at the beginning, or can be anywhere? Because I am affraid of that what is written in the manpage of resize_reiserfs, that you have to create a new partition ON THE SAME CYLINDER, now if fdisk writes the informations about the new partition for example at the start of the partition, maybe everything is corrupted now, otherwise if fdisk doesnt change data on disk around the new partition maybe there is some hope.
    But What could happen??

    then I did reiserfsck /dev/sdb5, and got cannot find superblock answer.

    Then i decided to delete /dev/sdb5 and create the same /dev/sdb5 with the same cylinders as before, that is: starting 5475, ending 20064, and I realized something strange:

    My new fdisk output of the /dev/sdb5 now looks like this:
    /dev/sdb5 5475 20064 117194175 83 Linux
    compared with the original one (before doing stuff):
    /dev/sdb5 5475 20064 117194143+ 83 Linux

    I see two differences, the number of BLOCKS differ and there is a + (PLUS).
    What does this mean? How can number of blocks differ, if the disk cylinders for the partition are the same??

    Okay, then i ran reiserfsck on /dev/sdb5 again and the output is still the same:
    -----------------------------------
    reiserfs_open: the reiserfs superblock cannot be found on /dev/sdb5.
    Failed to open the filesystem.

    If the partition table has not been changed and the partition is
    valid and it really contains a reiserfs partition, then the
    superblock is corrupted and you need to run this utility with
    --rebuild-sb.
    --------------------------------------

    I tried then rescuing with parted, but seems like reiserfs is not supported, because it didnt find my lost partition

    But I have bad experiences with --rebuild-sb, and this is my last option really

    Now I really dont know what to do more. Not even where to start recovering.
    Maybe these answers would help (if anybody knows?):
    - Is the data and superblock on my device really corrupted? Or is just because maybe the start of the partition is not the same as before?
    - Did fdisk currupted a superblock on the disk?
    - Are the informations of a new number of blocks any useful?
    - Is there any program like parted, that searches for the superblock of a reiserfs on the disk?

    Aahh, I am so sad really. I ... boo, all pics, scripts, everything gone.

    can you please give me an idea where to start .. if there is any hope left?
    Any of you have an idea what could go wrong already at the first step?

    Thank you for reading this!!!!!

    Hope this will never happen to anyone ..

    Peter

  2. #2
    Just Joined!
    Join Date
    Oct 2007
    Posts
    1
    the same happened to me. I was able to recover the partition using testdisk.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •