Find the answer to your Linux question:
Results 1 to 4 of 4
I have a Debian Sarge machine without X and I wanto to mount an external hard disk as user, so I modified /etc/fstab by adding this line: Code: /dev/sda1 /mnt/usb ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2006
    Posts
    17

    Problem with USB hard disk


    I have a Debian Sarge machine without X and I wanto to mount an external hard disk as user, so I modified /etc/fstab by adding this line:

    Code:
    /dev/sda1       /mnt/usb        vfat    rw,users,auto   0       0
    but I can't mount it:

    Code:
    roberto@ferro:~$ mount -t vfat /dev/sda1 /mnt/usb
    mount: only root can do that
    I don't find a solution, I read some tutorial but it makes me confused about fstab options.

  2. #2
    Linux Guru anomie's Avatar
    Join Date
    Mar 2005
    Location
    Texas
    Posts
    1,692
    You've correctly added the users option to allow users to mount the filesystem. Judging from the error message, it sounds like vfat filesystems do not honor that option.

    Did you test to see if you are able to mount it as root? If so, is setting the user up as a sudoer (to mount only) an option?

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    Code:
    /dev/sda1       /mnt/usb        vfat    defaults,umask=0 0 0
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Nov 2006
    Posts
    17
    I solved with

    Code:
    /dev/sda1    /mnt/usb    vfat    rw,noauto,user,uid=1000     0   0
    and I can mount with

    Code:
    mount /mnt/usb
    Thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •