Find the answer to your Linux question:
Results 1 to 5 of 5
I have just installed Debian (Knoppix) linux and the 2.6.5 kernel on my machine. Before I blew away my windows partition, I backed up all important data to an external ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2004
    Posts
    1

    USB Hard Drive


    I have just installed Debian (Knoppix) linux and the 2.6.5 kernel on my machine. Before I blew away my windows partition, I backed up all important data to an external USB 2.0 Hard DIsk (this is actually a generic enclosure model ME-720 which contains a Maxtor 20 GB IDE drive). I experimented with other distros... Red Hat 9 saw the drive, but I could never mount it and of course it worked flawlessly under Windows XP. I have done the apt-get upgrade and tried a lot of things, but this system doesn't even assign it a SCSI ID. I really need to get my data back off the drive and any help is appreciated.

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    You'll need to compile some SCSI emulation modules into your kernel for this to work. You need SCSI emulation, SCSI generic, and the usb-storage module. If you have a source tree installed (ls /usr/src), then you can compile them as modules and insmod them. If not, you'll need a new kernel.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Linux User
    Join Date
    Jan 2003
    Location
    Cardiff, Wales
    Posts
    478

    try

    it might get treated as a USB keyring drive. if so I wrote a tutorial on this.

    check out
    http://iscavision.com/2004/index.php.../usbdrives.php

    let me know if it helps. the rest of the site is very much under construction.

    cheers

    Kris
    No trees were harmed during the creation of this message. Its made from a blend of elephant tusk and dolphin meat.

  4. #4
    Just Joined!
    Join Date
    May 2004
    Posts
    1
    Worked for me dude thanx

    Using Fedora Core 1, & a Maxtor OneTouch 120GB, works perfect...

  5. #5
    Just Joined!
    Join Date
    May 2004
    Location
    Hamilton, Canada
    Posts
    13
    I'm using a hard drive based video player (MPAvio) with Knoppix KDE (CD bootable version).

    Knoppix auto detected and mounted the drive. However, It won't let me transfer files to the drive. It gives me an error whenever I try to copy or move a file.

    Any suggestions?

    Need any more info before answering?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •