Find the answer to your Linux question:
Results 1 to 2 of 2
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    'nother Zip drive problem in Mandrake 10


    Well, folks,

    I have been googling all night trying to find the solution to this problem. Seems others have had it but I can't find the solution...

    I have a 100 MB Zip drive, on the parallel port. I got it working under RedHat 9, with some trouble. Now I'm trying out - or mirating to - Mandrake 10, and was happy to see that the Mandrake install detected the zip drive .

    Trouble is, though it gets auto-mounted, I can't see the files on the zip disk - and can't access them.

    I've tried unmounting and mounting, editing /etc/fstab and so forth but can't get it right. I have a hunch it might be something with the permissions but then I should at least be able to read the files as root.


    Here's what I get on a ls-la (as root) in the /mnt directory:

    [root@localhost mnt]# ls -la
    total 19
    drwxr-x--- 5 root adm 4096 May 9 23:57 ./
    drwxr-x--x 21 root adm 4096 May 9 23:51 ../
    drwxr-xr-x 2 root root 4096 May 7 11:11 cdrom/
    drwxrwxrwx 2 root root 7168 May 9 23:58 floppy/
    drwxrwxrwx 0 root root 0 May 9 23:51 zip/



    This is my (current state of) fstab:


    /dev/hda1 / ext3 defaults 1 1
    none /dev/pts devpts mode=0620 0 0
    /dev/hda6 /home ext3 defaults 1 2
    /dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
    none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
    none /mnt/zip supermount dev=/dev/sda4,fs=auto,--,iocharset=iso8859-1,codepage=850 0 0
    none /proc proc defaults 0 0
    /dev/hda5 swap swap defaults 0 0


    And this is my mtab:

    /dev/ide/host0/bus0/target0/lun0/part1 / ext3 rw 0 0
    none /proc proc rw 0 0
    none /proc/bus/usb usbdevfs rw 0 0
    none /dev devfs rw 0 0
    none /sys sysfs rw 0 0
    none /dev/pts devpts rw,mode=0620 0 0
    /dev/ide/host0/bus0/target0/lun0/part6 /home ext3 rw 0 0
    none /mnt/floppy supermount rw,sync,dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,codepage=850 0 0
    none /mnt/zip supermount rw,dev=/dev/sda4,fs=auto,--,iocharset=iso8859-1,codepage=850 0 0


    TIA
    Mattias

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    In the comma delimited option list, try adding rw and exec. You can also add umask=022. Then remount the disk and see what happens.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •