Find the answer to your Linux question:
Results 1 to 6 of 6
This fault appeared suddenly. With key+shift only "3" prints. My OS is Suse10.2 but I have also WindowsXP and other versions of Suse installed for tinkering with. Since other installations ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    18

    Vanishing GBP character from Keyboard.


    This fault appeared suddenly. With key+shift only "3" prints.
    My OS is Suse10.2 but I have also WindowsXP and other versions of Suse installed for tinkering with. Since other installations print normally it must be something to do with the Suse10.2 installation. I have had a look at the keyboard module using Yast2 but I didn't see anything that meant anything to me as a means of refreshing the original installation. My books do not make any reference to keyboard mapping or the like so I am stuck. Is there anyone , please, who can give me a line on investigating the problem?
    With thanks.
    John ker.

  2. #2
    Linux User Oxygen's Avatar
    Join Date
    Jul 2004
    Location
    Hartlepool, England
    Posts
    392
    Out of interest, you haven't happened to change font have you? Can you manually insert the character in Open Office?
    Graham - You'd better Use Linux!

    I'm registerd Linux user #397030. What about you?

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    18

    #1 john_ker Just Joined! Join Date: Mar 2005 Posts: 4 Vanishing GBP character

    I have not changed font, not knowingly anyway.
    I opened OpenOffice word processor and key+shift still prints "3".
    The pound sterling character is not among the "special characters".
    I use Latex and "\pound" prints the character.

    Thanks for your interest.

  4. $spacer_open
    $spacer_close
  5. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    open terminal and execute 'setxkbmap us'.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  6. #5
    Just Joined!
    Join Date
    Mar 2005
    Posts
    18

    Vanishing GBP character from Keyboard.

    I do indeed seem to have a problem with the keyboard configuration it seems.
    I was unfamiliar with "setxkbmap us" and did a bit of googling, looked at the man page and checked the application was on my computer. I tried it out on my "practice" installation and sure enough the layout changed to North American and "gb" changed it back again. However, with my "operational" installation I got the following error message both as user and root which seemed to indicate a problem to which I don't really understand the question, never mind the answer. So, I am still no further forward - although I do know a little more than I did thanks to the help I've had.

    john@jonsbox:~> setxkbmap gb
    Couldn't interpret _XKB_RULES_NAMES property
    Use defaults: rules - 'xorg' model - 'pc101' layout - 'us'
    Couldn't find rules file (xorg)

    I got the same message using "us"

  7. #6
    Just Joined!
    Join Date
    Mar 2005
    Posts
    18

    Vanishing GBP character from Keyboard.

    It is all very educational investigating these problems but it is quick just to reinstall on an alternative partition especially if you have all data files backed-up and ready to go. Problem solved.

    When you find yourself in a hole: stop digging.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •