Find the answer to your Linux question:
Results 1 to 4 of 4
Hi everyone, I recently made a server with 2 SATA drives on RAID running on CentOS. CentOS didn't have the drivers for the SATA drives so I had to pass ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    4

    "Grub _" / "Grub hard disk error" help


    Hi everyone,

    I recently made a server with 2 SATA drives on RAID running on CentOS. CentOS didn't have the drivers for the SATA drives so I had to pass all-generic-ide to the grub when booting. It was working fine for about a week... until this morning.

    It started when I noticed that I couldn't access the server. I went to it to check, and heard some clicking sound. I tried to locate the clicking sound but couldn't find it. I'm pretty sure it wasn't from the hard disks because when I'd touch the computer frame, I can feel the clicking, but when I touch the hard disks, I couldn't feel the clicks. There was an error, which, stupid me, I didn't take not of. I thought that since this happened once before and a reset fixed it, I just restarted the computer.

    On boot, I started to get that error:

    "Grub _" where the cursor just blinks. I searched forums and it seems like that the GRUB has been corrupted. Knowing the computer was on RAID and the /boot was on both drives, I tried to boot up with either drive connected. In one, I get the same "Grub _" error, on the other, I get a "Grub hard disk error" message.

    I have important files and I'd like to get them out before messing around. I'd like to, in order of preference:

    1) Just boot normally and get rid of this problem, or
    2) Reinstall the OS but making sure I don't touch the RAID partition that stores the data, or
    3) Boot via a live CD, mount the RAID, and transfer those files out.

    What do you guys suggest I do, and, if I could be guided, I'd be grateful. I'm a newbie... still

    Thank you

  2. #2
    Just Joined!
    Join Date
    Jan 2007
    Posts
    4

    unknown filesystem type "linux_raid_member"

    Btw, I've booted in Ubuntu live CD and tried to mount the /dev/sda1 or /dev/sda2 but I get a message:

    unknown filesystem type "linux_raid_member"

  3. #3
    Just Joined!
    Join Date
    Jun 2009
    Posts
    1
    Quote Originally Posted by rmmt View Post
    Btw, I've booted in Ubuntu live CD and tried to mount the /dev/sda1 or /dev/sda2 but I get a message:

    unknown filesystem type "linux_raid_member"
    If you're sure that this is a RAID1 member, you can try to force it into the correct filesystem type while mounting (if you write anything to it, it will be out of sync and with unpredictable result, so use also -o ro). For example if the RAID1 contains ext3 filesystem:

    mount -t ext3 -o ro /dev/sda1 /mnt

  4. #4
    Just Joined!
    Join Date
    Jan 2007
    Posts
    4
    Thanks for answering! However, I don't have access to that machine anymore.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •