Find the answer to your Linux question:
Results 1 to 3 of 3
Whenever i log in, i get the following message: ****** Sound server informational message: Error while initializing the sound driver: device /dev/dsp can't be opened (Permission denied) The sound server ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    seb
    seb is offline
    Just Joined!
    Join Date
    May 2004
    Posts
    2

    [AUDIO] Cant open device


    Whenever i log in, i get the following message:

    ******
    Sound server informational message:
    Error while initializing the sound driver:
    device /dev/dsp can't be opened (Permission denied)
    The sound server will continue, using the null output device.
    ******

    I have tried to change the permissions of /dev/dsp, by
    chmod 777 /dev/dsp as root, and this is only a temporary solution.
    I run MDK 10.0 official (2.6.3-7mdk), and i used to have audio output - but i lost it when i upgraded to KDE 3.2.2.

    Any help much appreciated!

    Seb

  2. #2
    Just Joined!
    Join Date
    May 2004
    Location
    U.K.
    Posts
    8

    [AUDIO] Cant open device

    Hello
    This is just a message from the arts sound server in KDE, which is used for system sounds within KDE, if you go into the KDE control panel you can disable the arts sound server.
    Can you play sounds through Xmms or the CDplayer ?

  3. #3
    seb
    seb is offline
    Just Joined!
    Join Date
    May 2004
    Posts
    2
    I cant play audio AT ALL without changing the permissions...

    I have played around with /etc/security/console.perms but i have had no success what so ever in getting audio without manually changing permissions everytime i log in.

    Please remember that my problem only started happening when i upgraded to kde 3.2.2. Previous to the installation, my audio was fine.

    I tried to add another user, and when i logged in as that user - audio worked. They were not part of the audio group, and everything was standard. however, now when i log in - no audio...

    Any help is much appreciated.

    Seb

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •