Find the answer to your Linux question:
Results 1 to 4 of 4
After editing /etc/X11/xkb/symbols/inet, /etc/X11/xkb/rules/xfree86, XF86Config-4 and creating a .xmodmap file in my /home dir, I got all special keys being recognized by the system. I succeeded in assigning commands to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Posts
    10

    logitech elite keyboard and keybindings


    After editing /etc/X11/xkb/symbols/inet, /etc/X11/xkb/rules/xfree86, XF86Config-4 and creating a .xmodmap file in my /home dir, I got all special keys being recognized by the system.
    I succeeded in assigning commands to almost all special keys except for the rew , fwd, stop and play/pause keys in the multimedia part of the keyboard.

    The media special key has xmms assigned to it, for rew, fwd and play/pause keys I assigned xmms command lines, but instead of affecting the already opened xmms instance, it opens another one and try to apply the assigned command...I've already unchecked the "enable multiple instances" in xmms prefs. (i.e.: xmms is playing, when I press fwd special key, another instance of xmms opens highlighting the next song in the play list, an error message saying that my soundcard is "busy" appears and anything else happens).

    Xmms command lines:
    Code:
    keycode 153 = logitech_fwd > xmms -f
    keycode 144 = logitech_rew > xmms -r
    keycode 162 = logitech_playpause > xmms -t
    I'm using enlightenment as the wm and was just wondering if it' d be feasible to apply a command line that could assume the already opened instance intead of opening another one.

    Any help would be very much appreciated.

  2. #2
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    Sorry i cant help but what you did is quite cool if i may say so.. please post some info on what you did cus i would like to do the same!

  3. #3
    Just Joined!
    Join Date
    Apr 2004
    Posts
    10
    variant:
    I have just followed this tutorial at Linux Questions org.

    The issue with xmms was solved as soon as figured out that "enable multiple instances" in
    options > prefs > options was not really unchecked.
    All the special keys are working here (including the multimedia ones), my elite keyboard is not a cordless one but the tutorial worked pretty well.
    BTW: for the go and back keys I haven't figured out its actual function for windows user cause I haven't installed the itouch software under windoze (only my wife uses it). My option s was to customize it to work under enlightenment as "exit" and "resize window".
    Good luck.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2004
    Posts
    10
    hello, variant!!!
    have you tried to get the same thing I have here with my keyboard.
    Share your experience with us. Long time has gone, I'm anxious to know

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •