Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
Hello at all I have a serious problem with Linux installations on my machine. I've tried several distributions, all of them having the same problem. When I installed the distribution/run ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! robz0rz's Avatar
    Join Date
    Apr 2007
    Location
    Germany
    Posts
    19

    Unhappy acpi=off disables my USB mouse


    Hello at all

    I have a serious problem with Linux installations on my machine. I've tried several distributions, all of them having the same problem. When I installed the distribution/run the live-cd, I need the two boot parameters noapic and acpi=off. After some research, I found out that acpi=off casts my USB mouse (Logitech G3) unusable.

    Ubuntu and co. need noapic acpi=off to boot the Live system, and in these distributions, my mouse doesn't work.

    Gentoo has the same problematics as Ubuntu.

    Fedora Core managed to boot the installation process (in X11) with only noapic, but in order to boot after the successful installation, I still need to use the doomed acpi=off. That command kills my USB mouse.

    Slax runs from the live-cd without any boot parameters, and my mouse works in it.

    I've had other problems with Debian and openSUSE, so these distributions are not an option either.

    I just downloaded an iso from Slackware, but I don't believe this is a wise choice for a first time Linux installation. I don't have that much Linux experience, and I want to start with something else.

    I would rather just solve the problem of my mouse not working. I'm not afraid of recompiling the kernel with some extra drivers. Maybe the solution is easier, and using another parameter instead of acpi=off or changing some BIOS settings can do the trick. I am totally lost though. This particular problem has really been upsetting me.

    As of the moment, I have a successful installation of Fedora Core 6 on my harddrive, so whatever people can come up with to try and help me will be tested on that.
    I already connected an old PS/2 mouse to test if that would work, and the PS/2 mouse does work in all cases.

    Some hardware info:
    MoBo: ASUS M2N-SLI Deluxe
    CPU: AMD Athlon 64 X2 Dual Core processor 4200+
    GPU: NVIDIA GeForce 7600GT
    HDD: MAXTOR 7F300F0 (300GB, S-ATA)
    Mouse: Logitech G3 (connected over USB)

    Thank you for any help

  2. #2
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    As I didn't know what acpi means, I had s short look at http://acpi.sourceforge.net/.

    "Du meine GŁte", kann ich da nur sagen. Aber was soll's.

    They only thing I can hope is that this mouse works also without this acpi configuration as USB mice are generally not a problem at all if the mouse don't bear rare features with them.

    This is now a standard procedure described already many times here in the forum but here it goes again.

    First thing is to look at the output of the command line program "dmesg". Check the output before and after plugging the USB cable in and unplugging it again. There should be some output maybe even specifying a driver.

    Then, "/sbin/lsusb" and "cat /proc/bus/usb/devices" are your friends. Launch them also with the USB cable plugged in and removed.

    "/sbin/lsmod" gives you a list of drivers loaded as kernel modules.

    With the vendor and product ID gained from "cat /proc/bus/usb/devices" you can also do a Web search (this gives you mainly detailed technical output ) and find out what driver you could need or what special issues this device might have.

    Another place to look for might the config file for the X11-Window system with config files xorg.conf (?) or XF86Config (?). The latter is the older one but still in use sometimes.

    Under the section input device you may to specify for example "auto" as protocol or something else. Don't know if acpi would mess around with this.

    Here some example output. Some strings could help also with a Web search together with the name of your mouse, if needed.

    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    # Option "Protocol" "MouseSystems"
    Option "Protocol" "auto"
    Bus Error: Passengers dumped. Hech gap yo'q.

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    toggle 'Legacy USB Support' in BIOS.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. #4
    Just Joined! robz0rz's Avatar
    Join Date
    Apr 2007
    Location
    Germany
    Posts
    19
    Thanks ofr the long and detailed reply dilbert! I'll get on it when I find time tonight.

    I already toggled USB Legacy Support before, it used to be on, now it's off. I remember my mouse not functioning with it set to 'on', and my USB keyboard plugged into a PS/2 port using a plug only works with it turned 'off'. I'll try toggling it again, and I'll just plug my keyboard into a USB socket if it appears to fix my problem after all.

  5. #5
    Just Joined! robz0rz's Avatar
    Join Date
    Apr 2007
    Location
    Germany
    Posts
    19
    Oh my, I have a bad feling that the outcome of this is not good...

    dmesg: Nothing changed after unplugging/replugging the mouse.
    /sbin/lsusb: Didn't return anything at all.
    cat /proc/bus/usb/devices: No such file or directory

    My guess would be that my USB doesn't work at all after disabling acpi. I'm not quite sure what acpi is about anyway, but would reflashing my BIOS be a possible solution maybe..? I don't know what these results mean really...

  6. #6
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    "dmesg" should always notify some changes on the USB sockets. But I have here a crappy cable that sometimes doesn't. Seems to be a hardware issue of the cable's hub inside. Reversing the ends of the cable always makes it work again.

    "/sbin/lsusb" should always give at least error messages. Did you try it as root, too?

    The proc file can be disabled, but that would be a rather strange setup for a desktop box. Is there anything under "ls /proc" ?

    Maybe you have to check the BIOS settings. USB could be disabled.

    I read something on this acpi Web page that the Linux setup of devices should behave in the same way as on a Windoze box. That means switching from "plug&play" to "plug&pray".
    Bus Error: Passengers dumped. Hech gap yo'q.

  7. #7
    Just Joined! robz0rz's Avatar
    Join Date
    Apr 2007
    Location
    Germany
    Posts
    19
    Quote Originally Posted by dilbert View Post
    "dmesg" should always notify some changes on the USB sockets. But I have here a crappy cable that sometimes doesn't. Seems to be a hardware issue of the cable's hub inside. Reversing the ends of the cable always makes it work again.
    Maybe that means that my entire USB support is turned off, because it's handled over the acpi on my specific motherboard with this specific chipset and this specific USB controller. Just guessing around here.

    "/sbin/lsusb" should always give at least error messages. Did you try it as root, too?
    Haven't tried as root yet, will do.

    The proc file can be disabled, but that would be a rather strange setup for a desktop box. Is there anything under "ls /proc" ?
    Will try

    Maybe you have to check the BIOS settings. USB could be disabled.
    If USB would be turned off in the BIOS, I bet my mouse, my Bluetooth and my external harddrive wouldn't function in Windows.

    I read something on this acpi Web page that the Linux setup of devices should behave in the same way as on a Windoze box. That means switching from "plug&play" to "plug&pray".
    It should behave the same with acpi, but since my computer (like a lot of newer computers) has a faulty acpi, I need to turn it off in irder to boot.

    My guess would be that USB is turned off all together by turning off ACPI, but during the boot, I saw some Bluetooth stuff being initialized. I have a Bluetooth USB peripheral, but I don't know wether FC6 always inits BT, or only when it finds a BT device. If the latter is true, then my idea of USb being turned off is wrong. I'll look into flashing my BIOS and executing the commands with sudo. Thanks for your support

  8. #8
    Just Joined! robz0rz's Avatar
    Join Date
    Apr 2007
    Location
    Germany
    Posts
    19
    I tried all the given commands as root, but it gave me the same output. I did not even get an errormessage for /sbin/lsusb. Please help me guys, I would love to start using Linux (with my mouse that is)

  9. #9
    Linux Newbie dilbert's Avatar
    Join Date
    Sep 2006
    Location
    Yorkshire, GB
    Posts
    237
    Quote Originally Posted by robz0rz View Post
    I did not even get an errormessage for /sbin/lsusb.
    If it said "command not found" you could search with locate if the locate database is set up: "locate lsusb" or with find: "find . -name lsusb".

    The dot searches from the actually directory, so you could repacle the dot with "/bin", "/sbin/", "/usr" or search the entire box with "cd /" and then run the find command with the dot.
    Bus Error: Passengers dumped. Hech gap yo'q.

  10. #10
    Just Joined! robz0rz's Avatar
    Join Date
    Apr 2007
    Location
    Germany
    Posts
    19
    Nope, sorry, it really didn't output anything.

    Code:
    []$ /sbin/lsusb
    []$
    I don't get any message, it just does the same as if I typed an empty echo...

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •