Find the answer to your Linux question:
Results 1 to 5 of 5
I can't seem to get my sound to work for my linux. Here's my pc info: O/S: ubuntu linux (CD Version) Sound Card: Creative Sound Blaster Audigy I've been searchin ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2007
    Posts
    12

    Sound not working for linux


    I can't seem to get my sound to work for my linux. Here's my pc info:

    O/S: ubuntu linux (CD Version)
    Sound Card: Creative Sound Blaster Audigy

    I've been searchin the net for some drivers for my sound blaster for linux but i think i'm doing something wrong. Sorry i'm new to linux.

  2. #2
    Just Joined!
    Join Date
    May 2005
    Posts
    22

    Smile

    What is the exact type of your sound card?

    What version of audigy?

    Is it PCI or PCI express?

    What is the output of "lspci" command related to your sound card?
    Is there any IRQ conflict?

    http://doc.gwos.org/index.php/AudioC...c/SB_Audigy_LS

    Try lsmod command on terminal / command line (as root user).

    Perhaps you can try ubuntu LiveCD first.

  3. #3
    Just Joined!
    Join Date
    May 2007
    Posts
    12
    PCI Version. (i'm not quite sure what exact version it is, is there a program to check this or do i gotta open my pc?)
    Umm to my knowledge there is no IRQ Conflict (whatever that may be :S ).
    In the settings my linux detects the sound blaster card (if that's of any importance).

    I am using ubuntu livecd (well it's not live anymore fully hdd installed).

    What's this wiki link you gave me? Can i dl the driver or something?

  4. #4
    Just Joined!
    Join Date
    May 2005
    Posts
    22

    Smile

    Try to unmute / increase volume

    Try the following command:

    dmesg | grep -i IRQ
    dmesg | grep -i audigy
    dmesg | grep -i sound
    dmesg | grep -i audio
    dmesg | grep -i blaster

    What is the output of lsmod / lspci related to the sound card?

    Have you try the modprobe command on the link?

  5. #5
    Linux Guru
    Join Date
    Nov 2004
    Posts
    6,110
    I believe there can be trouble with the Audigy, but it is relatively easy to fix. You need to go into the sound mixer and disable digital output. Sound should kick in right away.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •